iMac Snow G3 500MHz ethernet out of order: HELP!

9 posts / 0 new
Last post
Offline
Last seen: 9 years 5 months ago
Joined: Nov 24 2004 - 04:18
iMac Snow G3 500MHz ethernet out of order: HELP!

Hi!
Welcome back APPLEFRITTER! I am pleased the site is up and running again Smile

I have a problem with my iMac G3 the ethernet port does not seem to work anymore Sad when linked to a switch/hub (known to be in perfect working order) the link led doesn't light-up and in OSX the adapter doesn't show up anymore in the network prefs.

Would anyone have any idea as to what might be wrong?

Thanx for the help Wink

coius's picture
Offline
Last seen: 4 years 1 month ago
Joined: Aug 25 2004 - 13:56
just a hunch..

your ethernet contoller is dead. I had this happen on an ibook G3 clamshell. hope you have airport.
anyway, as to go about fixing it, IIRC the ethernet controller is built-on to the board. no daughtercard. So the only thing you can do to get it back, is to get another board

when you find yourself in the company of a halfling and an ill-tempered dragon, remember, you do not have to outrun the dragon...

Check out my site :
http://www.geocities.com/coiuspcrepair/index.html

themike's picture
Offline
Last seen: 6 years 4 months ago
Joined: Jul 21 2004 - 19:33
or get a new ethernet

or get a new ethernet card....

EDIT:
wait....no....sorry.

Offline
Last seen: 9 years 5 months ago
Joined: Nov 24 2004 - 04:18
D-Link DWL-G122

I got a D-Link DWL-G122 which works fine, I haven't tried to open the Snow yet as I can't be bothered, but I shall check it out soon. If I get a new MoBo I recon it will have to be exactly the same model... or can I upgrade somehow?

aladds's picture
Offline
Last seen: 1 year 3 months ago
Joined: Dec 26 2003 - 16:21
disabled?

In Network prefs if you go to Network Port Configurations in the second pull down menu you might find it's been disabled.

Offline
Last seen: 11 years 6 months ago
Joined: Dec 26 2003 - 16:21
If...

If your 500MHz board has ATi Rage 128 Ultra graphics acceleration, you can put a 600 or 700MHz board in with no problems. If it has a Rage 128 Pro, 500MHz is the limit.

Yes there are other ways of explaining this, but I chose what is(to me) the easiest.

Offline
Last seen: 9 years 5 months ago
Joined: Nov 24 2004 - 04:18
Upgrade

Hmmm... I must check what board I have... Thanx for the precious information Wink

The ethernet card is definitly duff Sad

Offline
Last seen: 1 year 1 month ago
Joined: Feb 23 2005 - 05:27
dwl-g122??

Please tell me how you got this card to work!!! I went nuts trying to find an 802.11g usb 2.0 card that would work under os x. I ended up giving up and getting the 802.11b version (dwl-122) but I'd kill (maybe) for a chance to get a higher speed connection.

Oh, for the original poster, there are usb ethernet cards that should do the trick, anybody got a good list?

Offline
Last seen: 9 years 5 months ago
Joined: Nov 24 2004 - 04:18
YES of course :-)

GO HERE!

You find the explanation and a link to the CORRECT DRIVERS

Edit: I am the original poster that is why I installed the DWL-G122

Log in or register to post comments