cc65/ProDOSi: Error #64 loading stub in Apple2Enh program

5 posts / 0 new
Last post
Offline
Last seen: 3 months 3 weeks ago
Joined: Nov 12 2022 - 16:50
Posts: 197
cc65/ProDOSi: Error #64 loading stub in Apple2Enh program
AttachmentSize
Package icon advskel.zip20.23 KB

Hi!  I'm currently working on debugging my AdvSkel65 program.  Right now, there are two bad bugs with it: 1. most 128k ports seem to execute the wrong verb, and 2. the Apple2enh ports are having problems loading a low memory stub: I'm getting the monitor just after the stub was supposed to load.  Debugging code reveals gthat I'm getting error #64: Invalid Path.  When I look at the disk image with CiderPress, the path seems correct.  The path is "/PRODOS203/LOWMEM," and I attached the image.  I don't understand why I'm getting that.  :(  Any advice would be helpful.

Offline
Last seen: 3 months 3 weeks ago
Joined: Nov 12 2022 - 16:50
Posts: 197
BTW, I'm using ProDOSi wth

BTW, I'm using ProDOSi wth the program.

Offline
Last seen: 3 months 3 weeks ago
Joined: Nov 12 2022 - 16:50
Posts: 197
I'm glad.  :)

I'm glad.  :) 

This is in response to a deleted spam post - Tom

Offline
Last seen: 6 hours 57 min ago
Joined: Jun 6 2020 - 10:50
Posts: 406
Harry Potter wrote:I'm glad. 
Harry Potter wrote:

I'm glad.  :)

It's a spam bot, spamming links that are potentially dangerous. 

Offline
Last seen: 3 months 3 weeks ago
Joined: Nov 12 2022 - 16:50
Posts: 197
Good news: I fixed the second

Good news: I fixed the second bug!  It was with ProDOSi: apparently, the file open function was getting the wrong filename.  I fixed that bug.  I need to upload the fixes to the internet.  The other bug seems to occur only with the 128k Plus4.

Log in or register to post comments