Logitech Keyboard and Mouse

13 posts / 0 new
Last post
macintoshme's picture
Offline
Last seen: 9 years 1 week ago
Joined: Sep 19 2004 - 20:55
Posts: 150
Logitech Keyboard and Mouse

I just got a new iMac G3, I didn't have a USB Mac mouse. I hooked up the logitech setup, and the keyboard worked perfectly well. I hooked up the mouse and it seemed to lag, ebig time. Any one had a similar experience. What is the fix.

Offline
Last seen: 17 years 9 months ago
Joined: Dec 26 2003 - 16:21
Posts: 584
Define "Lag".

What exactly do you mean?

Offline
Last seen: 16 years 7 months ago
Joined: Jun 30 2005 - 19:08
Posts: 88
This might help you "word03"

http://en.wikipedia.org/wiki/Lag

Offline
Last seen: 17 years 9 months ago
Joined: Dec 26 2003 - 16:21
Posts: 584
Duh?

Not really worth a thoughtful response.

macintoshme's picture
Offline
Last seen: 9 years 1 week ago
Joined: Sep 19 2004 - 20:55
Posts: 150
Mouse Lag

When I move the mouse, it doesn't move on the screen for a good 5-10 seconds. When it does move, it jumps to where it was supposed to go. If you want an example, think of when your mac is computing alot of data at once and all the GUI interfaces are in slow motion. On mine however, it is only the mouse. The keyboard and finder act in real time.

Mac me

Offline
Last seen: 17 years 9 months ago
Joined: Dec 26 2003 - 16:21
Posts: 584
Try a different USB port, fai

Try a different USB port, failing that- get a different mouse.

TJH
Offline
Last seen: 14 years 4 days ago
Joined: Mar 28 2005 - 18:48
Posts: 52
Before you go ahead and buy a

Before you go ahead and buy a different mouse replace the batteries in your mouse and keyboard. Also how far away from the receiver are the keyboard and mouse, because if they are really far away or the signal is interfered with by lots of wires etc. then you will have that problem.

macintoshme's picture
Offline
Last seen: 9 years 1 week ago
Joined: Sep 19 2004 - 20:55
Posts: 150
Mouse and Keyboard

The mouse and the keyboard are near the computer. I have tried them far away also. I also changed the batteries, but new ones made no difference. I know that they are both perfectly funtional, because I used them a day before with my fathers PC.

TJH
Offline
Last seen: 14 years 4 days ago
Joined: Mar 28 2005 - 18:48
Posts: 52
Did you try just restarting?

Did you try just restarting? On my linux machine at least whenever I boot up then plug in my logitech stuff it lags like crazy, but a reboot always fixes it. Not sure if the same thing is happening to you though, or even what causes it etc.

macintoshme's picture
Offline
Last seen: 9 years 1 week ago
Joined: Sep 19 2004 - 20:55
Posts: 150
Restarted

No difference. I am starting to think that buss syncronization is off. I nee this to work because it is the only usb mouse I have access to.

TJH
Offline
Last seen: 14 years 4 days ago
Joined: Mar 28 2005 - 18:48
Posts: 52
Thats really weird. Are you r

Thats really weird. Are you running OS9 or OSX?

Offline
Last seen: 7 months 5 days ago
Joined: Jan 19 2005 - 23:30
Posts: 700
on another note of logitech k

on another note of logitech keyboards, i have one that has always worked fine for me untill i updated the osx to the latest 10.3.9 now every time i try to use the special keys nothing works and the latest drivers from logitech dont work any better. just thought id chime in on that...

macintoshme's picture
Offline
Last seen: 9 years 1 week ago
Joined: Sep 19 2004 - 20:55
Posts: 150
Problem Solved

While booting up yesterday, I was toying with the mouse. I saw that the mouse on the screen was moving properly until the extensions started loading. I disable almost all the extensions, and slowly am turning them back as needed. I am quite enjoying a functional mouse. Can't think of why I didn't try that before.

Log in or register to post comments