Trying to identify "sg501" in Apple Studio Display CRT 17...

5 posts / 0 new
Last post
Offline
Last seen: 1 week 1 day ago
Joined: Nov 25 2019 - 20:12
Posts: 2
Trying to identify "sg501" in Apple Studio Display CRT 17...

Hi,

I'm trying to bring an Apple Studio Display CRT 17 back to life, a blueberry model. The unit I have worked, but exhibited a terrifying pop when turned on, and thus needed a flyback transformer replacement. I managed to source one and have a friend install it, but after doing so we noticed a component next to the flyback transformer was busted. It appears to be a glass resistor, but the thing is busted open so we can't read the value to replace it. With the new flyback in place, we get no pop anymore, and we can get a CRT glow, but no picture, and we suspect that resistor is a big reason why.


That resistor is labeled sg501, as seen here:

 

 

I actually found this forum by looking for info on this component, by finding this topic here: https://www.applefritter.com/content/apple-studio-display-crt-17-vga

 

It appears the user Oddball at one point had access to just the monitor I am servicing. Would he, or someone else, please help me in finding the value of this resistor so I can bring this beautiful monitor back to life? Much appreciate any consideration!

 

Offline
Last seen: 9 hours 58 min ago
Joined: Jun 18 2010 - 13:54
Posts: 176
That is NOT a resistor.

That is NOT a resistor.

 

It is a Spark Gap probably used to prevent high voltage from damaging internal components of he CRT. Since the monitor worked before you replaced the flyback, is it safe to assume that you may have damaged the SG when you swapped the flyback? In any case, see if there is a short across the part; if so that could definitely cause your problem. You need to find out what the arc voltage of the spark gap is so that you can replace it. Unless someone has the same unit or a schematic/parts list and can get you the exact part number or specifications, you could look at similar monitors and take a guess.

Offline
Last seen: 9 hours 58 min ago
Joined: Jun 18 2010 - 13:54
Posts: 176
The other possibility...

The other possibility...

 

is that the flyback replacement CAUSED the spark gap to go! That would indicate an entirely different issue. Unless you feel comfortable trying to measure the voltage across the gap (assuming it's not shorted or after removing it), your next best approach would be to swap back in the old flyback and try to restore operation to where it was when you started.

 

I'm not convinced that the flyback was the cause of your original popping issue. Replacing it did make the pop go away, but probably because it is no longer generating any High Voltage. Any signs of HV (e.g. static on the CRT face or usual HV "sounds")?

Offline
Last seen: 1 week 1 day ago
Joined: Nov 25 2019 - 20:12
Posts: 2
jeffmazur wrote:

jeffmazur wrote:

The other possibility...

 

is that the flyback replacement CAUSED the spark gap to go! That would indicate an entirely different issue. Unless you feel comfortable trying to measure the voltage across the gap (assuming it's not shorted or after removing it), your next best approach would be to swap back in the old flyback and try to restore operation to where it was when you started.

 

I'm not convinced that the flyback was the cause of your original popping issue. Replacing it did make the pop go away, but probably because it is no longer generating any High Voltage. Any signs of HV (e.g. static on the CRT face or usual HV "sounds")?

 

The term "pop" is perhaps too soft to describe what we heard. The guy fixing my CRT recoiled in horror when we turned it on and he heard the pop. It was violent, sounded like glass shattering, and would fill the air with static electricity. It sounded like degaussing, but amplified to an incredible rate. The screen would sort of spark in one corner, then the image would fade in. The image would be unstable, too -- shrinking and growing as the brightness of the image on display would change.

 

We think maybe the flyback transformer we replace it with was not compatible even though it was advertised as. It was actually lacking 3 pins! The original flyback transformer had 15 pins, ours had 12. That said, we've sourced a new one and are having it shipped in and we'll try that.

 

To help anyone else who might ever stumble upon this topic, we actually found the listing for the spark gap through a facebook group called the CRT collective. It's a Mitsubishi DSP-120M-A21F. We ordered some replacement spark gaps and we'll try again shortly after they arrive. Cross your fingers, I'll post the results!

Offline
Last seen: 12 hours 23 min ago
Joined: May 22 2013 - 20:37
Posts: 165
Thank you for posting this. I

Thank you for posting this. I have a few old CRT's that I like. Good luck.

Log in or register to post comments