Disk ][ Interface card problems

14 posts / 0 new
Last post
Offline
Last seen: 1 month 4 days ago
Joined: Feb 24 2021 - 13:25
Posts: 16
Disk ][ Interface card problems
Long time lurker, first time poster.

I have 2 cards from 2 systems.  Both are giving me issues.

650-104 - Green lines on boot

650-X104 - Screen is just green garbage

 

I also have a I/O controller 655-0101-B, that lets the Apple IIe boot but beeps a second time with the attached error.  (Seems to sort of work in my II Plus, but gives LOAD ERR?)

 

Is it possible all my cards are bad?

Offline
Last seen: 1 day 13 hours ago
Joined: Jan 1 2020 - 15:56
Posts: 79
Drive?

I got the exact same kinds of errors with different cards and it turned out the cards and drive electronics itself were fine but the "head loader" - the little felt button inside the spring arm - was worn flat and not pressing the opposite side of the disk against the head with enough pressure.  A dirty head can also give these exact same errors too.  What kind of drive are you using - the metal Disk II type or the newer plastic one?  The newer plastic one is the worst design with the head loader felt pad but I've run into it with Disk II's as well.  40 year old felt pads go flat.  Try fluffing it up with some isopropyl alcohol and a needle or pin and let it dry a few minutes and see what you get.  

 

also edited: make sure that the bottom of your motherboards aren't shorting out on the metal case bottom too.  Just now noticed in the picture that it isn't even mounted.  On some of the Apple II boards they rely on the board to be secured to the mounts as those screws provide ground bridges from some parts of the board to others, and without the board mounted and securely attached to the little metal risers you will have certain portions of the board with no ground.  But maybe you have also tried it with the boards installed.  I woulc check the drive head itself and clean it well with a q-tip and alcohol, and then check the head loader button/felt pads to make sure they are even present nd also fluffed up.

Offline
Last seen: 1 month 4 days ago
Joined: Feb 24 2021 - 13:25
Posts: 16
I will have to give my drives

I will have to give my drives a good cleaning.  That would explain that error.

 

With the Disc ][ Interface card however, I turn on the system and it does nothing except produce a green screen of garbage.  Remove the card, no problem, boots?  That is with no drives connected?  Must have bad prom or something?

 

 

Offline
Last seen: 1 month 4 days ago
Joined: Feb 24 2021 - 13:25
Posts: 16
I could have more problems

I could have more problems with this IIe...  when I do a diag I get this screen?

Offline
Last seen: 1 day 13 hours ago
Joined: Jan 1 2020 - 15:56
Posts: 79
Garbage screen

Ah yes if you turn on the computer with just the card installed in Slot 6 but nothing attached to it it should just sit there and hang until you press Ctrl-Reset to get to a Applesoft basic prompt "]"  You shouldn't get anything at all other than the Apple ][ or //e logo and a hung computer.  So perhaps that card is corrupt.  

Offline
Last seen: 1 day 13 hours ago
Joined: Jan 1 2020 - 15:56
Posts: 79
Diag

Ah yes that is not the normal diagnostic screen.  You should see a bunch of little squares all over the screen for a bit, and then either System Ok or Kernel OK depending on whether it is an enhanced //e or not or else a summary of which RAM chip(s) it finds bad.  If your ram is socketed you might try lifting and reseating them

Offline
Last seen: 1 month 4 days ago
Joined: Feb 24 2021 - 13:25
Posts: 16
thellmer wrote:Ah yes that is
thellmer wrote:

Ah yes that is not the normal diagnostic screen.  You should see a bunch of little squares all over the screen for a bit, and then either System Ok or Kernel OK depending on whether it is an enhanced //e or not or else a summary of which RAM chip(s) it finds bad.  If your ram is socketed you might try lifting and reseating them

Soldered :( 

Offline
Last seen: 1 day 13 hours ago
Joined: Jan 1 2020 - 15:56
Posts: 79
Ram

Ugh.  Figures.  Means it's never been touched.  Probably the awful MT ram.  If you have some 4164 ram chips you can often piggyback it atop the soldered chip(s) without removing the soldered one u ntil you find the one(s) which have gone bad.  It worries me though that the self test isn't finishing or identifying the bad ram addresses though - usually even with bad ram at least the test finishes and lists them all out since the test itself runs from ROM.  If you leave the screen alone does it sit there forever?  It can take some time for the test to identify and list the bad ram locations

Offline
Last seen: 2 days 2 hours ago
Joined: Apr 26 2016 - 08:36
Posts: 173
What happens when you power

What happens when you power up with no cards installed and with the closed-apple key pressed?

 

Does it go through the system diagnostic checks?

 

Offline
Last seen: 1 month 4 days ago
Joined: Feb 24 2021 - 13:25
Posts: 16
thellmer wrote:Ugh.  Figures.
thellmer wrote:

Ugh.  Figures.  Means it's never been touched.  Probably the awful MT ram.  If you have some 4164 ram chips you can often piggyback it atop the soldered chip(s) without removing the soldered one u ntil you find the one(s) which have gone bad.  It worries me though that the self test isn't finishing or identifying the bad ram addresses though - usually even with bad ram

Just left it for over an hour, no change.

Offline
Last seen: 1 month 4 days ago
Joined: Feb 24 2021 - 13:25
Posts: 16
baldrick wrote:What happens
baldrick wrote:

What happens when you power up with no cards installed and with the closed-apple key pressed?

 

Does it go through the system diagnostic checks?

No change, just RAM:

Offline
Last seen: 2 days 2 hours ago
Joined: Apr 26 2016 - 08:36
Posts: 173
appleiiapple wrote:baldrick
appleiiapple wrote:
baldrick wrote:

What happens when you power up with no cards installed and with the closed-apple key pressed?

 

Does it go through the system diagnostic checks?

No change, just RAM:

 Well I guess it's trying to tell you that you have bad RAM I suppose, but it's hard to know which RAM chip is at fault.

The enhanced IIe could more or less pinpount the offending chip, but in this case the best course of action is to replace all the RAM, install sockets and put in some new 4164 chips in there.

41256 chips would work also with pin 1 lifted.  Those are pretty easy to find.

Offline
Last seen: 2 weeks 6 days ago
Joined: Mar 31 2020 - 19:55
Posts: 848
thellmer wrote:Ugh.  Figures.
thellmer wrote:

Ugh.  Figures.  Means it's never been touched.  Probably the awful MT ram.  If you have some 4164 ram chips you can often piggyback it atop the soldered chip(s) without removing the soldered one u ntil you find the one(s) which have gone bad.  It worries me though that the self test isn't finishing or identifying the bad ram addresses though - usually even with bad ram

One trick that you can do here, is to clip the legs of the RAM chips, and solder a machine pin socket directly to the cut legs. this prevents damaging vias or anything if you are not experienced with desoldering, and as a bonus, you do not need to remove the mainboard to do it. you merely need to cut the legs near the top to leave enough surface area, and carefully tin all of them, then tin the socket pins; then fuse them with a fine point iron. 

 

You can spread the original legs to make it easier and more level, and a flush cutter to trim them all to even height. It may not look pretty, but it will be the safest way to add sockets in place of those 4164s with no risk to the mainboard. 

Offline
Last seen: 1 month 4 days ago
Joined: Feb 24 2021 - 13:25
Posts: 16
baldrick wrote:appleiiapple
baldrick wrote:
appleiiapple wrote:
baldrick wrote:

What happens when you power up with no cards installed and with the closed-apple key pressed?

 

Does it go through the system diagnostic checks?

No change, just RAM:

 Well I guess it's trying to tell you that you have bad RAM I suppose, but

Thanks for the info, I will look into this.

Log in or register to post comments