Pismo LCD Lamp Dead?

5 posts / 0 new
Last post
mudogramx's picture
Offline
Last seen: 16 years 5 months ago
Joined: Jun 21 2005 - 13:16
Posts: 34
Pismo LCD Lamp Dead?

A few days ago while using my PowerBook Pismo, I noticed that the screen was starting to fade to a pinkish color. Within seconds all of the color was gone. The LCD had been flaky for a couple days. I've read that it could just be the lamp that burned out. If so, thats an inexpensive repair. I was wondering what you guys thought? I really don't want to shell out a bunch of money for a whole new LCD.

Thanks

Offline
Last seen: 13 years 6 months ago
Joined: Jan 23 2006 - 23:30
Posts: 62
pismo

It could be that, or a loose cable. Someone I knew had a Powerbook, and when they jiggled the cable, the screen would turn abnormal. If it is a cable, it shoukdn't be that hard to fix once you get a replacement one. If it is the LCD itself, don't bother fixing it. Just get a refurbished ibook or something. A new LCD panel would be like $
300 I think.

dankephoto's picture
Offline
Last seen: 5 months 3 weeks ago
Joined: Dec 20 2003 - 10:38
Posts: 1900
backlight

You're correct, it's the backlight lamp that's gone. The pinkish color is a dead giveaway sign of a failing lamp.

If you've got the chops to replace, by all means do it. Otherwise, those LCDs are going for under $100 these days, so if your time is worth more than the $$, just replace the LCD. Heh heh, I'm guessing not however, since you've even asked the question, like most of us here on AF, you probably aren't rolling in dough. Blum 3

dan k

mudogramx's picture
Offline
Last seen: 16 years 5 months ago
Joined: Jun 21 2005 - 13:16
Posts: 34
I reset everything

I went ahead and reset the PRAM, NVRAM, and PMU. The screen turned back on. I'm so glad it wasn't a dead LCD. Thanks for your input, though.

Offline
Last seen: 13 years 6 months ago
Joined: Jan 23 2006 - 23:30
Posts: 62
wow, lucky you! Yeah, those

wow, lucky you! Yeah, those machines had issues with the PMU i remeber, and some wouldn't even turn on at all! congrats on fixing yours!

Log in or register to post comments