g4 processor upgrade

13 posts / 0 new
Last post
olikicksmacs's picture
Offline
Last seen: 8 years 10 months ago
Joined: Dec 20 2003 - 10:38
Posts: 252
g4 processor upgrade

im looking at getting a g4 powermac with a limited budget. ive spotted this on ebay:

Link

and i'd guess it was a sawtooth? but need to know what processors i could put in it to upgrade it. This will be my second g4 and my first processor upgrade so im not too clued up!

thanks

eeun's picture
Offline
Last seen: 1 year 3 weeks ago
Joined: Dec 19 2003 - 17:34
Posts: 1895
It's a tough one...since in t

It's a tough one...since in the description it's both a 350 and 450MHz G4. :/

...but if the AGP description is correct, then Sawtooth it is. I'd double-check with the seller before bidding. You don't want to get stuck with a Yikes board.

There's a lot of processor upgrade options. If it's a 350, then going up another 100 MHz is a really cheap jump.

There've been a few threads, mostly Alk's adventures, regarding adding processors from the Quicksilvers. Problem with the Sawtooths is the later processors get in the way of the secondary IDE connector on the motherboard. If you only need two devices off the built-in IDE you can remove the connector to make room (there's also the need to add 12V to one of the lugs on the new processor).

I'm guessing third-party processors are heading out of your budget plans.

Watch the auctions for a while. Figure out what speeds you need and whether it's worth buying a G4, plus an upgrade, versus holding out for a Digital Audio or better. The DA I finally got by watching and waiting was cheaper than a Sawtooth I'd been outbid on earlier (and the 133MHz bus does, at least in my experience, give quite a boost to the system).

olikicksmacs's picture
Offline
Last seen: 8 years 10 months ago
Joined: Dec 20 2003 - 10:38
Posts: 252
i forgot to add, im an impuls

i forgot to add, im an impulse buyer, so its already in the post :]

im pretty confident its a sawtooth board, as he has another g4 on sale with PCI in the title, making it a Yikes!

when it arrives, ive got a 120gb hdd waiting for tiger and a 40gb hdd for os9. Ive also got 4x 256mb sticks of ram to put in.

So i think i could save some pennies and fork out enough for a third party processor. im hoping giga designs do international shipping, because im pretty sure theyre the company to go with

can someone tell me, why some sawtooth's can accept dual processors where others cant? is it just luck of the draw, logic board revision or something else?

thanks

Woody G4's picture
Offline
Last seen: 16 years 8 months ago
Joined: Jun 3 2007 - 21:59
Posts: 5
I am in the process of doing

I am in the process of doing the same thing. I got a 350 MHz sawtooth on ebay for $90. So far I have used mostly parts from my "frankinPC" and spent a total of $100 in upgrades.

I overclocked the CPU to 450MHz, put in 1GB RAM, DVD-RW, 120GB HDD, GeForce2 MX 400 video card, and Linksys wireless card...all for free (from old PC).

I just upgraded my video card again to FX 5200 ($20 on ebay). Let me tell you, an upgraded video card really beats the stock ATI it comes with. The two cards I used are PC video cards. I just flashed the BIOS to macintosh.

I also put in a PCI USB 2.0 card. ($34 @ staples).

I am really enjoying this G4. Next I am going to get an upgrade CPU...probably 1.4 GHz. Unfortunately a dual CPU won't work in this motherboard (wrong Uni-N version).

If you need any help or advice let me know. I would enjoy sharing what I have done and learned.

Hawaii Cruiser's picture
Offline
Last seen: 7 years 1 month ago
Joined: Jan 20 2005 - 16:03
Posts: 1433
Processor upgrades

Goodies:

OWC

Woody G4's picture
Offline
Last seen: 16 years 8 months ago
Joined: Jun 3 2007 - 21:59
Posts: 5
OWC I plan on getting my u

OWC

I plan on getting my upgrade CPU from there....and an ATA card.

olikicksmacs's picture
Offline
Last seen: 8 years 10 months ago
Joined: Dec 20 2003 - 10:38
Posts: 252
ive got an old pc mx420 lying

ive got an old pc mx420 lying around, could that be flashed for mac?

still hasnt arrived. getting a bit miffed.

thanks

Woody G4's picture
Offline
Last seen: 16 years 8 months ago
Joined: Jun 3 2007 - 21:59
Posts: 5
Is it the GeForce4 MX 420. If

Is it the GeForce4 MX 420. If so it SHOULD be. I found most of my info at Strangedogs. They are all about flashing PC video cards to work on Macs. They even have the Mac ROMs.

Each card is a little different according to manufacturer though. My GeForce2 MX 400 was made by MSI. I used the generic ROM and played with it with the help of one of the programmers at Strangedogs, and got it working.

My FX 5200 worked right away with the ROM I downloaded from there.

BTW, is it AGP and how much vram does it have ?

olikicksmacs's picture
Offline
Last seen: 8 years 10 months ago
Joined: Dec 20 2003 - 10:38
Posts: 252
yes it is a geforce4, its agp

yes it is a geforce4, its agp and has 64mb ram. I *think* creative labs made it, but im not 100%, I'll have a look at that strangedogs site you mentioned

thanks!

olikicksmacs's picture
Offline
Last seen: 8 years 10 months ago
Joined: Dec 20 2003 - 10:38
Posts: 252
yes!

it came! haha, im sooo happy with it. great machine. upgraded the ram and hard drive, got my mx420 and completely mucked up the flashing, so ive ordered a radeon 7000 off ebay, and hope i am more successful with an ATI flash. next the processor upgrade...

olikicksmacs's picture
Offline
Last seen: 8 years 10 months ago
Joined: Dec 20 2003 - 10:38
Posts: 252
ok, this machine is slowly st

ok, this machine is slowly starting to do my head in! tried to install panther or tiger, neither would work, both keep crashing during installation. Then tried to intall os9, same, keeps crashing during install. Tried zapping pram and swapping about the ram but no luck. As i am typing this, the os9 install cursor has just turned to a bomb. doesnt look good Beee

any ideas?

thanks

Hawaii Cruiser's picture
Offline
Last seen: 7 years 1 month ago
Joined: Jan 20 2005 - 16:03
Posts: 1433
Can you describe the specs on

Can you describe the specs on all the RAM you're trying? And the harddrive model? Is the harddrive zero formatted nice and clean?

olikicksmacs's picture
Offline
Last seen: 8 years 10 months ago
Joined: Dec 20 2003 - 10:38
Posts: 252
ive got in 2 sticks of 256mb

ive got in 2 sticks of 256mb pc133 standard sdram that i pulled out of my imac g3, and were working fine in there.

The model of the harddrive is a Seagate st380020a which i just bought off ebay and was guaranteed working

thanks

Log in or register to post comments