Comatose iMac G5

7 posts / 0 new
Last post
iamdigitalman's picture
Offline
Last seen: 2 years 7 months ago
Joined: Mar 1 2004 - 22:18
Comatose iMac G5

Hey all. Just got this sexy piece of hardware for a song with box, 2 of 4 Styrofoam inserts, pro keyboard and manual, and want to get it working. It has no hard drive or bracket, but optical drive, RAM, airport/bluetooth board, and modem board. It also has a brand new power supply. I opened the machine up, and did not see any bad capacitors on the motherboard. From what I have read, the original ones had a + or X pattern on the top (where the vent is), and replaced ones had a k. I had a eMac 1.25ghz motherboard with burst caps, so I know what they look like. Plus, those were orange on the outside, and these are black.

It does show some signs of life. When I plug it in, LED #1 on the motherboard comes to life. From what I have read, it means the motherboard is getting power. I tried using the internal power button, tried removing the CR2032 battery and booting, tried replacing the CR2032 with the good one in my remote for my car and booting (the one in there was still good too. I put it in my remote and hit the panic button and it worked.)

Specs:

iMac G5 Revision B Ambiant Light Sensor edition
1.8ghz G5
17" LCD
512mb of RAM
no hard drive (originally 160gb according to the box)
new power supply
built in bluetooth 2.0+EDR and 802.11g

Even if I can't get this thing working, it's worth more on fleabay than I paid for it.

Dr. Webster's picture
Offline
Last seen: 16 hours 14 min ago
Joined: Dec 19 2003 - 17:34
Try a different RAM module in

Try a different RAM module in it. I had a coworker's HP laptop on my desk at work the other day; when you pressed the power button the lights on it lit up but it never booted. I reseated the RAM and it was back to normal again.

iamdigitalman's picture
Offline
Last seen: 2 years 7 months ago
Joined: Mar 1 2004 - 22:18
I don't have any other PC3200

I don't have any other PC3200 to put in it. I did remove the module, and AFAIK, it should beep for no ram. Even if it was bad ram, it should beep for that too, right?

But if need be, I will go get a new 1gb stick for it. Was planning on maxing it out anyways.

cwsmith's picture
Offline
Last seen: 6 months 1 day ago
Joined: Oct 13 2005 - 08:23
AP/BT

Try disconnecting the AirPort / Bluetooth board from the MLB and see if that makes any difference at all. Once in a while I've seen a bad BT board completely wig a machine out.

iamdigitalman's picture
Offline
Last seen: 2 years 7 months ago
Joined: Mar 1 2004 - 22:18
I disconnected the ap/bt boar

I disconnected the ap/bt board, optical dive, and the modem board and tried booting without them. Still nothing.

I swear, the caps are perfect, so it should be booting. Unless there is something simple I am missing...

iamdigitalman's picture
Offline
Last seen: 2 years 7 months ago
Joined: Mar 1 2004 - 22:18
ok, just an update, I removed

ok, just an update, I removed the logic board, and inspected it topside and bottom side. Everything looks perfect. I don't understand what could be wrong with it.

It was a tad dusty (not nearly as bad as most computers I get), so I blew it out with some compressed air.

will reassemble it now and try booting it.

iamdigitalman's picture
Offline
Last seen: 2 years 7 months ago
Joined: Mar 1 2004 - 22:18
Update

I reassembled it, and nothing. I even put in an 80gb HD to test if that was it, still nothing.

This is getting frustrating...

Log in or register to post comments