MP3 file corruption

5 posts / 0 new
Last post
DrBunsen's picture
Offline
Last seen: 10 years 2 weeks ago
Joined: Dec 20 2003 - 10:38
Posts: 946
MP3 file corruption

About 2/3 of my MP3 library is corrupted. Some of them are really quiet, some have a delay in them (ie same sound played again a moment after the original) and some have a weird high pitched warbling noise in the background with heaps of distortion, like they were encoded at a really low bitrate. The only thing I can think of that I've done differently recently was to defrag the drive they're on with Norton Speed Disk.

So far this problem shows up in OS X QT Player and iTunes, with all other apps closed. I haven't tried any other players or OS 9.

Is there some way I can recover these files?

HFS+ drive, OS X, iTunes, OS 9 Norton Systemworks 1.0

Dr. Webster's picture
Offline
Last seen: 8 hours 30 min ago
Joined: Dec 19 2003 - 17:34
Posts: 1753
Have you tried burning some o

Have you tried burning some of the songs as an audio CD? I'd be interested to know what the CD ends up sounding like.

Offline
Last seen: 7 years 3 months ago
Joined: Dec 20 2003 - 10:38
Posts: 455
Has this corruption been gett

Has this corruption been getting worse as time goes on or did they all just get corrupted one day?

Either way, to me it sounds like hard drive issues (maybe logical or hardware).

Try uploading one of the mp3's that obviously has a problem and see if we get the same symptons. (no i am not advocating piracy, i'm just really curious if is the mp3 or your system).

DrBunsen's picture
Offline
Last seen: 10 years 2 weeks ago
Joined: Dec 20 2003 - 10:38
Posts: 946
Nope, it all just appeared at

Nope, it all just appeared at the same time as far as i know, or at least in a range over a couple of days. I was downloading some old radio plays and they previewed fine at first in Poisoned via Quicktime Player, then after they'd downloaded some more (they're 30 minute eps) they played corrupted. Then I noticed lots of other file had the same problem.

Hmmm. They're playing fine now. I think it might be a CPU overhead issue. Often when I'm online, the CPU meter sits on 97-100% for some time (iTunes, Poisoned, Eudora, Safari, XChat Aqua, Copypaste and the Finder, sometimes Acrobat Reader and Textedit on a G4/450 upgraded beige G3 with 512MB) CPU is running at between 50 and 80%. So I guess that was the problem...

Wow, Poisoned must be a real hog.

martakz's picture
Offline
Last seen: 13 years 3 months ago
Joined: Dec 20 2003 - 10:38
Posts: 634
Set poisoned's processor prio

Set poisoned's processor priority to low and see if the mp3s play better.

I had no trouble do simular things on a 333 iMac. Defrag the harddrive?

Log in or register to post comments