Barbershop pole spins when user logs in...

9 posts / 0 new
Last post
doug-doug the mighty's picture
Offline
Last seen: 1 month 2 weeks ago
Joined: Apr 14 2004 - 17:52
Posts: 1360
Barbershop pole spins when user logs in...

Machine:
15" Flatpanel iMac. 800MHz
X.2.8

Symptoms:

  • Two users exist on this machine, both are set up as Admins. One of these (the primarily used one) gets a perpetually spinning barbershop pole when trying to log in. The other user can log in without issue in less than 10 seconds.
  • Booted from an X.2 Install CD and ran Disk Utility - no problems found.
  • Problem started today when I logged off the main user - logged off with no issue.
  • Earlier today a power failure caused the machine to shut down, but I logged on after that and used it fin for several hours.
  • Already tried to reset nvram in OF

Problem:
I do not know what is wrong and need to fix it and it is my wife's machine and she is going to blame me and I did not do it and I need to make it better and I do not know what is wrong and I am out of beer and I need a good drink and I have been working on this for three hours now and someone please help!

aladds's picture
Offline
Last seen: 2 weeks 10 hours ago
Joined: Dec 26 2003 - 16:21
Posts: 297
Repair permissions?

Did you verify and repair permissions? This could stop a user from logging in. If not then chown the users folder to them as it may have been set up so a differernt user has access to the files.

So it'll be:

sudo chown -R username /Users/username

replacing username with the username

If it dosn't work it'll do no harm as it just sets the owner of all the files to that of the user.

doug-doug the mighty's picture
Offline
Last seen: 1 month 2 weeks ago
Joined: Apr 14 2004 - 17:52
Posts: 1360
yeah, sot of...

When I ran the Disk Utility, I did choose Repair, but I did not enter any special commands in OF as you describe.

DU said no problems were present.

The Czar's picture
Offline
Last seen: 7 years 8 months ago
Joined: Dec 20 2003 - 10:38
Posts: 287
I'm probably gonna show my di

I'm probably gonna show my digital age here, but I know on 68k Macs running OS 7, you can get a perpetual beach ball if the desktop file is damaged somehow. You held down option and command as you started the Mac, and all was well again.

I don't know if this applies to OS X, or if it would have any dire consequences, but that's what it looks like to me.

Cheers,

The Czar

tmtomh's picture
Offline
Last seen: 1 year 4 months ago
Joined: Dec 20 2003 - 10:38
Posts: 568
Fonts?

The Czar may be on to something here. OS X doesn't have a desktop file like Classic Mac OS does. But corrupt fonts can cause all sorts of problems when logging in under OS X.

Since one user is having problems while the other is not, I would suggest looking in [username]/Library/Fonts - that is, the Fonts folder inside the Library Folder, inside the user's Home directory. I would try dragging every font you find to the Trash (or just to some other non-font-storage place).

Since you can't log in to the user's account, you will have to find a way to get in to that directory. Another admin user canNOT gain the required access.

So, the easiest way would be to log in as root. If the machine is old enough to be able to boot into OS 9, you could get at it that way as well.

The only other thing I can think of is that the Mac might be looking for some server - did this user connect to an AFP server or something, and then not unmount the server properly?

Good luck!

Matt

doug-doug the mighty's picture
Offline
Last seen: 1 month 2 weeks ago
Joined: Apr 14 2004 - 17:52
Posts: 1360
hmmm...

I can try the font route by logging in as root.

As far as the AFP thing, I did have the machine connected to an iBook earlier in the day via AirPort and i think a connection timed out, but everything else seemed fine.

I also did realize that when I booted off the X disc, i had only the option to Repair, I have since gone in via the other Admin and run Repair Permissions. I will go through that a few times first to see if it clears something up.

doug-doug the mighty's picture
Offline
Last seen: 1 month 2 weeks ago
Joined: Apr 14 2004 - 17:52
Posts: 1360
update...

I did go in as root and reset the owner of all the [username] file to [username] via the permissions thing under Cmd+I and said apply to all sub folders.

I do not understand what aladds means as I am really green on these things (sudo, chown, ? - are these terminal commands?, OF?).

Re-ran permissions repair on disk. It keeps telling me:
"2005-05-08 18:41:31 -0400 - Repair of privileges has started
We are using special permissions for the file or directory ./System/Library/Filesystems/hfs.fs/hfs.util. New permissions are 33261
Permissions differ on ./usr/share/man/man1/less.1, should be -rw-r--r-- , they are -r--r--r--
Owner and group corrected on ./usr/share/man/man1/less.1
Permissions corrected on ./usr/share/man/man1/less.1
Permissions differ on ./usr/share/man/man1/more.1, should be -r--r--r-- , they are -rw-r--r--
Owner and group corrected on ./usr/share/man/man1/more.1
Permissions corrected on ./usr/share/man/man1/more.1
2005-05-08 18:49:03 -0400 - The privileges have been repaired on the selected volume."

To quote "Close Encounters" - 'This means something' but be damned if I know what.

Subsequent re-runs of Repair permissions give the same mesage.

Now what?

doug-doug the mighty's picture
Offline
Last seen: 1 month 2 weeks ago
Joined: Apr 14 2004 - 17:52
Posts: 1360
Resolution...

I tried the low-tech method. I created a new Admin user and copied over everything but the prefs. I was able to log in with this new user. Then I started incrementally moving prefs over. I was able to isolate that it was a pref problem and restore the original user to its prior state (although I did loos the dock setup in the process). I was never able to isolate the exact preference that was bad, but the whole process of moving things around did allow me o purge some old prefs that were no longer needed (removed apps and stuff).

Bottom line: things are working now and the only loss (as far as I can tell) was the arangement of the dock.

Thanks for all the ideas.

*Edit* - Moral of the story, always have a secondary, never-used (vanilla), alternate Admin for your machine. I I had not had this, I would not have been able to get in and activate the root user (at least no easy way I know of).

aladds's picture
Offline
Last seen: 2 weeks 10 hours ago
Joined: Dec 26 2003 - 16:21
Posts: 297
I know it's a bit late, but…

To explain that terminal comand (Yes, it is a terminal command):

sudo means "Superuser do" basically it runs the command as root

chown means "change owner" and it does just that

Log in or register to post comments