DWL-122 Strangeness

8 posts / 0 new
Last post
themike's picture
Offline
Last seen: 6 years 4 months ago
Joined: Jul 21 2004 - 19:33
DWL-122 Strangeness

I have a DLink DWL-122 (wireless USB adapter)which exhibits some strangeness- it disconnects from my network every few minutes. The thing is, it seems to be a software problem- resetting the support software will cause it to reconnect. From what I have been able to figure out, the DWL-122 is based on the Prism2 chipset, and using a generic Prism2 driver helps immensely. So, what I am wondering is, does anyone know of a generic Prism2 driver for Windows? Everything I have found is for Linux or OS X.
``theMike

Dr. Webster's picture
Offline
Last seen: 3 hours 37 min ago
Joined: Dec 19 2003 - 17:34
Those adapters are crap. I ha

Those adapters are crap. I had one for a while, and tried using it on both a Mac and a PC. In both cases, the signal would drop every couple minutes. I eventually invested in a wireless PCI card until I could pull Cat5 to my home office.

Offline
Last seen: 2 years 1 week ago
Joined: Dec 20 2003 - 10:38
Works fine with Windows...

Useless with Mac OS X. Apart from the dropped connections, mine caused kernel panics when OS X came out of sleep mode. I only used it a couple of times with Windows 98SE (ugh) but it was faultless. A colleage uses one with Windows 2000 and XP without problems too.

Phil

Offline
Last seen: 10 years 9 months ago
Joined: Dec 20 2003 - 10:38
I have one in OS X and it wor

I have one in OS X and it works fine-- except that it gets bloody hot for only drawing 5 volts. Use a differnt driver-- get onto versiontracker and find 1.4.7 (it's labeled as 1.0) and use that... oh, and before you disconnect it, choose "Quit Wireless status" from the menubar. Other than that, it's ok.

(Anyone got an Airport card?)

Offline
Last seen: 9 years 5 months ago
Joined: Nov 24 2004 - 04:18
G version

I use the G version of the DWL-122 so I get the 56Mbps Wink it works fine but I have to make sure I plug it in after having started the Mac up and take it out only once I have powered down. I noticed that it doesn't recognise correctly at startup...

Offline
Last seen: 9 years 9 months ago
Joined: Jun 5 2005 - 10:15
Crappy DWL-122

Might I ask which version of Mac OS X you're using?

The newest driver I've found was for OS X 10.2.

I've only used it on OS X 10.3 and 10.4 where I get kernel panics, if I start to use more network traffic than simple chat.

To me it looks like D-Link made some alpha-testing with OS X 10.2, and haven't bothered using the hardware since.

The Czar's picture
Offline
Last seen: 7 years 1 month ago
Joined: Dec 20 2003 - 10:38
Re: DWL-122 Strangeness

themike wrote:
So, what I am wondering is, does anyone know of a generic Prism2 driver for Windows?

What version of Windows are you using?

I found that with my D-Link gear, I'd install the drivers provided on CD from D-Link, and then use the built-in Windows 2000/XP wireless management tools. They always worked better than D-Link's utterly useless software package.

Cheers,

The Czar

Offline
Last seen: 9 years 5 months ago
Joined: Nov 24 2004 - 04:18
10.3.9

I am using 10.3.9 and I have no problems...

Log in or register to post comments