Help with formatting and installing DOS 3.3 onto a floppy for a Apple IIe

4 posts / 0 new
Last post
The Fruitarian's picture
Offline
Last seen: 2 months 10 hours ago
Joined: Sep 17 2019 - 15:05
Posts: 3
Help with formatting and installing DOS 3.3 onto a floppy for a Apple IIe

Greetings!

 

I just found an old Apple IIe and bought some floppies that are DS/DD and I am having some trouble formatting and installing certain games or programs onto a the floppy.

I did everything as instructed in this video: https://www.youtube.com/watch?v=_DRql_Z-d7k&t=105s

However once I put in the floppy, turn the Apple IIe on, type LOAD and play the audio it says loading INSTA-DISK but shortly after I get a CHKSUM ERROR.

 

Any help would be appriciated.

Flashmeister's picture
Offline
Last seen: 1 month 3 weeks ago
Joined: Sep 17 2019 - 02:17
Posts: 1
This checksum error happens

This checksum error happens before Insta-Disk starts writing?
 

If so, I think you are having issues with the audio levels during the cassette port loading...

Try adjusting the levels of whatever device you are using to play the audio file on (normally works bet max'ed, but you can try backing it off a little), and maybe even try another audio device...

 

I have a friend with a IIe that always has issues receiving files through the cassette port... Suspect maybe the input capacitor is bad... Normally his works when he tries the Lo-Fi files (slower but more reliable). My IIe always works with the Hi-Fi files on all my devices (iPhones and iPads).

 

If the process is failing during the disk writing, it is likely that you have a bad drive or bad floppy disk... (try another disk, or a 2nd-drive)
 

Apple drives do tend to need tune-ups regularly as the speed and amp bias often drifts out of spec... There are lots of utilities out there to set these (armed with a small screwdriver), but you likely first need to get a drive working (not sure if any of these utilities will run directly from audio file)

The Fruitarian's picture
Offline
Last seen: 2 months 10 hours ago
Joined: Sep 17 2019 - 15:05
Posts: 3
Yes it says "loading insta

Yes it says "loading insta-disk ETA 10 sec." But then it says checsum error.

Also the same thing happens if I do not put in the floppy, as if it does not tecognize it maybe? I also tried several new floppies but same error.

I will try to swap the disk drives.

Also, the audio loading method works, since I tried the one that loads it into the ROM so the volume is not a problem I think.

I will write back when I try the disk swap.

Thanks!

The Fruitarian's picture
Offline
Last seen: 2 months 10 hours ago
Joined: Sep 17 2019 - 15:05
Posts: 3
Well, success...kinda.

Well, success...kinda.

So it appears that there was an audio problem. I had the cable plugged into my speakers before but now I plugged it into my PC audio port. 

And this time it loaded into Insta-Disk but it does not load properly:

- Either it formats the disk successfully and writes something on and says checksum error or loading error or just error

- Either it does not format the disk at all (error).

Also when I restart the Apple II and put in the floppy and press CTRL, APPLE, RESET the disk starts loading the floppy into infinity or it tries to load something and it says  "File not found"

Also I did switched drive 2 with drive 1 because drive 1 did not work.

Log in or register to post comments