Apple Disk II does not start at all (no calibration)

5 posts / 0 new
Last post
Offline
Last seen: 2 weeks 16 hours ago
Joined: Jul 18 2020 - 04:00
Posts: 3
Apple Disk II does not start at all (no calibration)

Hi everybody,

 

This summer, my plan was to clean up my old Apple IIGS and transfer some floppy disks to a PC with ADTPro.

I've plugged-in everything, I've put a 3.5 inch disk in the drive, powered-on and it did boot well, after 25 years of hibernation. The demo that I was launching confirmed to me that the IIGS was working perfectly.

 

Alas, when I set the control panel to boot on slot 6 drive 1, where the Disk II 5'1/4 drive is connected to a controller card, nothing happens. The reader does not calibrate, the LED does not light up, nothing inside the drive is moving.

 

I can't see any fried chip on the contrller or on the top PCB in the drive (I have not taken it appart yet). I've tried the simplest things, like unplugging / re-plugging the controller board and every cable (carefully marking initial positions). I've pressed (gently) on all the PROMs and chips, to no avail.

 

If anyone has any ideas on how to proceed from there, I'm interested. :)

Offline
Last seen: 19 hours 6 min ago
Joined: Apr 13 2006 - 22:28
Posts: 122
"Your Card"?

Seeing as it sounds like you have a 5.25" drive connected to a controller card (as opposed to the disk drive port on the back of the IIgs), in the IIgs Control Panel do you have Slot 6 set to "Your Card"?

 

You will need to have it set to "Your Card" otherwise it will expect the drive to be connected to the disk drive port.

 

Offline
Last seen: 2 weeks 16 hours ago
Joined: Jul 18 2020 - 04:00
Posts: 3
Problem solved

Thank you Sir, I owe you a coffe. :-)

I've just made the adjustment you suggested and I am now the very lucky owner of a fully functionnal Disk II drive.

As a side note, booting with pr#6 right after exiting control panel did not work. I had to power off the IIGS to have it boot properly (being doing too much plug and play lately).

 

 

 

Offline
Last seen: 2 weeks 16 hours ago
Joined: Jul 18 2020 - 04:00
Posts: 3
ADTPro USB to 8-pin mini-DIN cable for about $25

Just a quick update to inform you that I've managed to successfuly transfer several disks from my IIgs to a PC laptop with ADTPro.

 

Just in case somebody is interested, I've built myself a USB to 8-pin mini-DIN cable for about $25 with the following parts :

 

- 8-Pin Mini-DIN Male to Male cable (I've got myself a used one on ebay for 2$)

 

- Connector DB9 RS232 D-SUB Serial Adapter

 

- USB 2.0 to Serial (9-Pin) DB-9 RS-232 Adapter Cable 6ft Cable [FTDI Chipset]

 

One important detail here is the FTDI chipset. I've read many good feedbacks on the net about it. As a matter of fact, no additional driver installation was required on Windows 10 to make it work.

 

To be able to build the mini-DIN to DB9 cable right (following schematics given here https://adtpro.com/connectionsserial.html), I had to test each wire of the mini-DIN cable to figure out which color was connected to which pin (it seems there is no industry standard for that).

Offline
Last seen: 4 days 8 hours ago
Joined: Mar 31 2020 - 19:55
Posts: 396
Jerome J wrote:Thank you Sir,
Jerome J wrote:

Thank you Sir, I owe you a coffe. :-)

I've just made the adjustment you suggested and I am now the very lucky owner of a fully functionnal Disk II drive.

As a side note, booting with pr#6 right after exiting control panel did not work. I had to power off the IIGS to have it boot properly (being doing too much plug and play lately).

 

 

If you are not using an original, full-height Disk ][, but for some reason you have a DuoDisk or a 5.25 UniDIsk on an I/O card, you can swap them to the normal drive bus port. In fact, you can build, or buy, an adapter, to use Disk ][ drives on the SmartPort. It is merely a matter of signal-matching. 

 

if you have a ROM 0 or ROM 1 //gs, clip out the battery and replace it. BOMW sell a uick install double-AA battery pack for that, or you can solder a new battery into place. The old one is by now dead and will not ssave your settings. OTOH, if you have a ROM3, then the battery is in a small enclosure and you can R/R it very easily. You need a battery to retain your control panel settings through power cycle. 

 

Log in or register to post comments