Apple IIe RAM problems...but I don't think the chip is the culprit

11 posts / 0 new
Last post
Dr. Webster's picture
Offline
Last seen: 16 hours 28 min ago
Joined: Dec 19 2003 - 17:34
Posts: 1706
Apple IIe RAM problems...but I don't think the chip is the culprit

I'm trying to fix a memory problem in a IIe. The self-test reports one chip is bad with the message:

RAM 0 0 0 0 0 0 1 0

So I desoldered the chip in position 12 (second from the right in the row of RAM chips) and installed a socket. Continuity between the socket and where the traces lead (ground or the pins of other RAM chips) looks good.

The RAM chip I removed was an MT 4264-15. I bought some replacements off of eBay and installed one in the socket (with the notch in the correct orientation). The self-test reports the same error.

I found some alternative replacement chips, as I've heard that these Micron chips have a tendency to fail. I dropped in a Mitsubishi M5K4614NP-15, and it came back with the error again, and also when I tried an MN4164P 8-15.

Out of curiosity I tried the self-test without a chip in the socket, and it never completed. It also showed garbage characters on screen (different than the blocks usually shown when the self-test starts). So having *any* RAM chip in the socket at least allows it to complete the self-test (albeit fail it).

The PSU voltages look good.

I don't have another machine to test these RAM chips in, unfortunately. I tried multiple of the replacement Micron chips and they all did the same thing. So unless I'm having very bad luck and the half-dozen RAM chips I've tried are all bad, I think the problem lies elsewhere. I just don't know what else to try. Thoughts?

Online
Last seen: 45 min 21 sec ago
Joined: Aug 18 2017 - 16:53
Posts: 111
There are 64kbit-DRAMs with

Deleted.

Oh, no, sorry. 7bit and 8bit refresh is not the problem.

 

Online
Last seen: 24 min 58 sec ago
Joined: Jun 16 2020 - 16:58
Posts: 165
Can you try a diagnostic

Can you try a diagnostic software instead? XPS should tell you what module is bad as well - if it runs.

 

I'm new to this world but if the module is good - could it be the MMU? Do you have an oscilloscope, can you check the data lines on the affected chip? I need to check the purpose of the MD bus, is that to select the chip and read its output? In that case, that comes from the 6502 directly. In any case, if you have a scope you could check what pins 2 and 14 are doing on the affected chip.

Dr. Webster's picture
Offline
Last seen: 16 hours 28 min ago
Joined: Dec 19 2003 - 17:34
Posts: 1706
OK, so I tracked down disk

OK, so I tracked down disk images for several diagnostics utilities. Of the four I tried, only Apple-Cillin II actually booted and ran (the others would either freeze when booting, or generate a "RELOCATION / CONFIGURATION ERROR" message (which is the same thing that other programs would do).

I ran the "low" memory tests, and there weren't any errors. Then I ran the "high" memory tests, and it started throwing errors at address 811B and continued until BD5B. Which chip on the motherboard would this correspond to?

Offline
Last seen: 8 hours 51 min ago
Joined: Nov 7 2019 - 13:49
Posts: 77
64K x 1bit

The RAM chips on the motherboard are 64K x 1 bit. Each chip stores one bit of a byte. That's why there are 8 of them... For each memory byte, all 8 chips need to work. You'd need to look at the bit pattern to tell which RAM chip was faulty.

Online
Last seen: 24 min 58 sec ago
Joined: Jun 16 2020 - 16:58
Posts: 165
I'm afraid I cannot help.

I'm afraid I cannot help. Would it be worth socketing the rest of the chips and try moving chips around - or replacing them one by one? It could be that what you get is a false error and the faulty chip is another one?

Did you check pins 2 and 14 of the chips? They go to the CPU.pins 26 to 33.

Offline
Last seen: 9 hours 59 min ago
Joined: Dec 20 2003 - 10:38
Posts: 442
I've found that the self test

I've found that the self test can't reliably tell which RAM chip is bad. Often it's a totally different chip.

amauget's picture
Offline
Last seen: 1 week 21 hours ago
Joined: Jan 3 2011 - 11:34
Posts: 292
You can try the XPS

You can try the XPS Diagnostic IIe : it will tell you which IC is bad if you will be able to load it.

Online
Last seen: 24 min 58 sec ago
Joined: Jun 16 2020 - 16:58
Posts: 165
he's not able to run it

he's not able to run it unfortunately.

 

I feel the best solution is to socket all chips and start shuffling/swapping them.

Offline
Last seen: 8 hours 51 min ago
Joined: Nov 7 2019 - 13:49
Posts: 77
YouTube video on repair

So, is Dr. Webster == "Mr. This Does Not Compute" on YouTube - or was this just an coincidence, that his latest YT video shows exactly the issue described above?

Apparently the solution to the issue was that the Apple IIe self-test shows the RAM chips as seen from the mainboards back, so RAM error  0 0 0 0 0 0 1 0 means RAM in position 7 (not 12) has to be replaced. The AppleFritter Forum is also briefly featured in the video:

https://www.youtube.com/watch?v=aZY-F57zZVs

 

Online
Last seen: 24 min 58 sec ago
Joined: Jun 16 2020 - 16:58
Posts: 165
ahah very interesting! Woz is

ahah very interesting! Woz is probably giggling when coming across these posts and videos! :D 

 

To be honest my next step would have been to socket all the chips and start swapping them around - you would have found which one caused the self test to show a different position very quickly! 

Log in or register to post comments