apple //e problems

12 posts / 0 new
Last post
Offline
Last seen: 4 months 3 weeks ago
Joined: Apr 14 2021 - 21:14
Posts: 6
apple //e problems
just picked up my first vintage computer, an apple //e. im having trobble getting it to run programs off floppy emu. some programs start but get stuck others shows strange text. when i power it on while holding the two apple keys it makes a strange noise and displays the work ram in the top left. shouldnt it do a ram check. any thoughts? thank
Offline
Last seen: 6 days 3 hours ago
Joined: Jul 14 2018 - 12:54
Posts: 70
It's difficult to see from

It's difficult to see from the smallness of your picture, but it does look like a RAM issue.  Provided that your //e is an un-enhanced model, then the noise you're hearing is normal.  If the system had passed diagnostic you would have seen "KERNEL OK" on your screen.  If you post the text on the screen, someone might be able to tell you more.

Offline
Last seen: 4 months 3 weeks ago
Joined: Apr 14 2021 - 21:14
Posts: 6
this is what i get when
this is what i get when trying to load a floppy from a floppy emu
Offline
Last seen: 4 months 3 weeks ago
Joined: Apr 14 2021 - 21:14
Posts: 6
And this is what i get when i
And this is what i get when i do a ram check. and its the normal //e
Offline
Last seen: 4 months 3 weeks ago
Joined: Apr 14 2021 - 21:14
Posts: 6
in high resolution mode ill
in high resolution mode ill also get ramdom pixles everywhere or it looks like this after a few seconts of looking mostly okay
Offline
Last seen: 6 days 3 hours ago
Joined: Jul 14 2018 - 12:54
Posts: 70
So you definitely have a RAM

So you definitely have a RAM issue.  The first image is a ProDOS load error.  If I recall, Donkey Kong loads from a different OS (likely DOS 3.something), so it's not as sensitive to RAM issues (it'll load, but be glitchy as it accesses the bad data bits).  Unfortunately, the self-test isn't telling you which chip has gone bad.  The way around this is to get some new RAM (4164 same as on a Commodore 64 and some CoCo's).

 If the chips are socketed, swap out each chip with a known good chip until you've isolated the bad.  If they're soldered in, you can piggyback the good chip over the chips on the board until you find all the bad chips.  Just make sure that all the legs on the good chip line up and are making contact with the legs on the board.  However, once you've isolated the bad chips, you will want to replace them.

Offline
Last seen: 4 months 3 weeks ago
Joined: Apr 14 2021 - 21:14
Posts: 6
Okay sweet thanks for the

Okay sweet thanks for the info. When you say piggyback does that mean literally holding it ontop of one that's soldered in making sure it has a good connection and try it?

Offline
Last seen: 6 days 3 hours ago
Joined: Jul 14 2018 - 12:54
Posts: 70
Yep.  Weird as it sounds.

Yep.  Weird as it sounds.  Though, if you get the pins right, the tension should hold the chip in place when you power on.  The idea is that the computer will default to the good chip, taking over the functions of the bad.

Offline
Last seen: 4 months 3 weeks ago
Joined: Apr 14 2021 - 21:14
Posts: 6
when i go online to buy some

when i go online to buy some new ram i cant find the same 4164 chips without a - 10,15,or 20 after 4164. what timing are the stock apple //e chips? 

Offline
Last seen: 6 days 3 hours ago
Joined: Jul 14 2018 - 12:54
Posts: 70
You know, I was never quite

You know, I was never quite clear on that.  From what I understand, just about any will work, so my guess is that the slower chips are the standard.  Or at the very least the slowest chip in the line will set the base speed for the rest.  As such if you use a faster chip it shouldn't make much difference to your //e. 

As I said, the chips used in the //e were interchangeable with a lot of 8-bit machines at the time.  Including the Commodore 64.  I've actually swapped RAM between a //e and C64, and vice versa, without a problem.   And Commodore was known for being cheap on their components.  So I don't think you can go wrong getting whatever's cheapest, as long as the brand is good.  No MOS and most will tell you to avoid MT as well.  But those are generally labeled 4264.  They're the same chip.  Just a different number.  But I can't tell you why that is.    It's also not uncommon to find those in //e's or C64's for that matter.

Online
Last seen: 1 hour 9 min ago
Joined: Apr 26 2016 - 08:36
Posts: 198
Bigbadbrad wrote:when i go
Bigbadbrad wrote:

when i go online to buy some new ram i cant find the same 4164 chips without a - 10,15,or 20 after 4164. what timing are the stock apple //e chips? 

Although the IIe can use 200 ns chips (the 4164-20) I always go for the 150 ns ones - the 4164-15

 

Jameco sell them.  They are used chips, but are tested.  The price is right.  Buy a whole set and keep them as spares.

https://www.jameco.com/z/4164-150-Major-Brands-IC-4164-150-DRAM-65-536-Bit-65-536x1-150ns-with-Page-Mode-DIP-16_41662.html

 

 

Offline
Last seen: 5 months 1 week ago
Joined: Apr 16 2021 - 13:11
Posts: 1
apple //e problems

Hi,

I am actually restoring an Apple IIe (my first one...), and I have faced the same issue and the IIe was frozen on this RAM message.

Now, after fixing, I have the Kernel OK message.

To know which RAM was the bad one, I have used this test:

 

CALL -151

C050 C053 C054 C057 N 265:FF N 266<265.BFFEM 266<265.BFFEV 265:0 N 266<265.BFFEM 266<265.BFFEV 34:14 (Return)

 

It will check the Rams by read/write and you can see the writing and the reading values. For mine, the writings were $FF and the reading were $7F. So, I have suspected the bit b7 which is located on the right side of the RAM bank. I have changed this chip, and it works now.

May be you can find the defective RAM with this test to know which bit is damaged (b0 is on the left side of the RAM bank, and b7 is on the right hand).

 

Hopping it could be helpfull,

Sorry for my poor english, writing from France.

 

Log in or register to post comments