Apple IIe misbehaving - diags not running, no serial boot etc

2 posts / 0 new
Last post
Offline
Last seen: 4 days 16 min ago
Joined: Feb 13 2020 - 16:52
Posts: 8
Apple IIe misbehaving - diags not running, no serial boot etc

Hi All,

Got an Apple IIe which is giving various issues - history of the machine is unknown, but apart from being dirty there appears to be no physical damage to the PCB or keyboard.

Issues are:

1. Refuses to boot to the on-board diagnostics - this was working and giving a SYSTEM OK message, but now ignores the Apple keys being pressed on power up

2. With a Super Serial card installed in slot 2 and typing IN#2, CTRL-A will sometimes give the 'Apple SSC:' prompt, sometimes not returning the ] prompt

3. Typing CALL -151 will usually enter the monitor, but sometimes is just ignored just going back to the ] prompt.

4. Using Freitz's SD card interface, gives his copyright message at the bottom of the screen but doesn't boot from any SD card.

The system was originally a standard IIe, but has been upgraded with a Rockwell 6502P4 CPU and the Enhanced ROM set - using a test routine from Chromatix correctly identifies the CPU as a CMOS version - the EPROMS were written and tested by Freitz so have no reason to suspect a problem with them.

It seem to boot reliabily to the Apple BASIC ] promt each time it is powered on, but Control-RESET is also ignored by the machine.

Any help, suggestions etc would be very much appreciated as I'm no Apple II expert and the knowledge I do have is old and very rusty.

 

Offline
Last seen: 4 days 16 min ago
Joined: Feb 13 2020 - 16:52
Posts: 8
ok, looks like I have at

ok, looks like I have at least two seperate faults:

1. The diags failing to start looks like a keyboard issue with  one of the Apple keys being intermittant so hopefully a strip and clean will fix

2. It seems that for some reason the IIe is having issues talking to the expansion slots - I've cleaned the connections but still have issues.

Log in or register to post comments