Apple IIe PAL Keyboard problems

5 posts / 0 new
Last post
robbo007's picture
Offline
Last seen: 1 day 13 hours ago
Joined: Dec 14 2011 - 06:39
Posts: 113
Apple IIe PAL Keyboard problems

Morning,

I've just fired up my second Apple IIe PAL and found Im having strange keyboard probelms.  There seems to be a delay when I press a key it then displays the text. Sometime nothing comes out. I press like 4-5 keys and then it starts working. Its very intemidant. I've run XPS diagnostics as this is a non enhanced apple IIe and the RAM, ROMS etc are all good. I've run the onboard diagnostics too and I get the KERNEL OK message. 

 

I've removed all cards too and tried a bare boot and same thing. I've removed and reconnected the keyboard to make sure it's connected properly. I've also swapped out the keyboard rom to make sure its not that. 

 

Any ideas? 

 

amauget's picture
Offline
Last seen: 1 day 19 hours ago
Joined: Jan 3 2011 - 11:34
Posts: 267
Evening,

Evening,

Have you tried to swap the Keybaord encoder ?

robbo007's picture
Offline
Last seen: 1 day 13 hours ago
Joined: Dec 14 2011 - 06:39
Posts: 113
amauget wrote:Evening,Have

amauget wrote:

Evening,

Have you tried to swap the Keybaord encoder ?

 

Hi, yes, I grabbed the "keyboard Rom" from the working Apple IIe and tried it. Still the same symptons. I've even connected the probamatic Apple IIe motherboard to the working Apple IIe's keuyboard to make sure its not a keyboard problem. Its must be a Motherboard problem. What else controls the keyboard commands? 

amauget's picture
Offline
Last seen: 1 day 19 hours ago
Joined: Jan 3 2011 - 11:34
Posts: 267
Hello,

Hello,

The keyboard ROM is not the keybord Encoder. It is located next to the keyboard ROM, on the right.  Ref is AY-5-3600-PRO.

 

 

robbo007's picture
Offline
Last seen: 1 day 13 hours ago
Joined: Dec 14 2011 - 06:39
Posts: 113
Yep, I swapped them both from

Yep, I swapped them both from the other working apple IIe. Very strange. 

Log in or register to post comments