Apple IIGS hardware failure

8 posts / 0 new
Last post
robbo007's picture
Offline
Last seen: 4 years 4 months ago
Joined: Dec 14 2011 - 06:39
Apple IIGS hardware failure

Hi all,
I downloaded the Apple IIgs Diognostic V3.0 image from Asimov ftp and ran it on my Apple IIGS because im having some problems. It detected the following errors.

Expansion RAM card not detected
Sound Circuitry Test Fail
Serial Test Failed

I've checked my expansion ram card and all looks fine. No burnt out chips and everything looks clean and in order. Not detected? Any ideas before I try and source another on ebay?

Sound Circuitry test failed??? Sound seems to work on the system not sure what this is refering too?

Serail test failed. (not lookpack) I posted a while back about problems with ADT-PRO. This was working then it just stopped working. Guess as its onboard nothing can be done to fix it?

Thanks,
Rob

speedyG's picture
Offline
Last seen: 16 hours 42 min ago
Joined: Nov 16 2011 - 07:45
Re: Apple IIGS hardware failure

related to RAMexpansion error:
Have you inspected the detected RAM in the control panel ?
does it also not see the RAM in the control panel ?
- if yes then it´s time to perform a RAM-IC´s test.
speedyG

robbo007's picture
Offline
Last seen: 4 years 4 months ago
Joined: Dec 14 2011 - 06:39
Re: Apple IIGS hardware failure

Hi SpeedyG.

I've inspected in the control panel a it does not register. Can you let me know how I can preform the RAM-IC's tests?

Thanks,
Rob

Offline
Last seen: 1 year 10 months ago
Joined: Jan 24 2005 - 16:20
Re: Apple IIGS hardware failure

Quote:
I downloaded the Apple IIgs Diognostic V3.0 image from Asimov ftp and ran it on my Apple IIGS because im having some problems.

Do you have an accelerator installed (specifially, a ZipGS)?

robbo007's picture
Offline
Last seen: 4 years 4 months ago
Joined: Dec 14 2011 - 06:39
Re: Apple IIGS hardware failure

No accelerator installed. Just the RAM card and the CFFA3000.

robbo007's picture
Offline
Last seen: 4 years 4 months ago
Joined: Dec 14 2011 - 06:39
Re: Apple IIGS hardware failure

No accelerator installed. Just the RAM card and the CFFA3000.

speedyG's picture
Offline
Last seen: 16 hours 42 min ago
Joined: Nov 16 2011 - 07:45
Re: Apple IIGS hardware failure

robbo007 wrote:
Hi SpeedyG.

I've inspected in the control panel a it does not register. Can you let me know how I can preform the RAM-IC's tests?

Thanks,
Rob

Hello Rob,

as far as i remember we had some debugging tasks several months ago with a Apple II+ or IIe.....
If you have for that computer a RAMvard with 1MB like the RAMworks II or the RAMworks III -
that catds also use 41256 or 42256 chips ( 256 kB x 1 Bit ) too. That cards also have Utilitydisks
containing RAMchip tests.
For the general basic test remove all 256 kB chips except the basic row that is soldered and set that
chips in antistatic foam besides.

Test the 1 MB II GS RAMexpansion card RAMcard only with the 256kB in the first soldered row nserted in the IIGS again.
Does the II GS recognize the card.
If not that card itself is bad.
If YES - the card and the first row of RAM is O.K.

then move to the IIe or II+.

Remove the RAMchips completely of the RAMworks Card and put them on antistatic foam besides.

Insert one row of the RAM chips to the RAMworks II or RAMworks III and run testutility.
Pay attention to insert the RAMchips in correct orientation to that card with notch of the RAMchips on correct side!
Identify the bad chips and mark them.

Test each row of the RAMchips row by row till all bad RAMchips are identified and marked.

Set back all RAMchips that have identified to be GOOD row by row to the II GS RAM expansion card and test card again in II GS. Beware before testing again that all RAMchips have been inserted with correct orientation ( same like the soldered ones ) with notches at the same side like the row with the soldered ones.

sincerely speedyG

robbo007's picture
Offline
Last seen: 4 years 4 months ago
Joined: Dec 14 2011 - 06:39
Re: Apple IIGS hardware failure

Hi SpeedyG,
Your right. We were troubleshooting my Apple IIe a while back. Pretty much working ok now Wink

With regards to my Apple IIGS Memory card problems. I removed all the chips only leaving the hard soldered chips. Card is still not detected. It does look like the card is faulty. I'll source another and test it.

I really hope my main board is not faulty as that would be a bummer.

Question: I'm using a UK Apple IIGS. Can I fit a USA Apple IIGs main board? Or are the voltages from the power supply different?

Thanks,
Rob

Log in or register to post comments