Drive //c Write Protect Issue

14 posts / 0 new
Last post
Online
Last seen: 7 min 5 sec ago
Joined: Jun 6 2020 - 10:50
Posts: 11
Drive //c Write Protect Issue

I recently picked up a Drive //c for my Apple //c, and found that it always thinks the disk is write protected.  I did some research, and I see you can wire in a switch to override this.  I'm not sure I want to do that at this point yet, but would like to troubleshoot a little further.

 

It seems like the //c drive is a bit of a hybrid of the Disk ][ and the Apple 5.25 I have for my GS.  It uses a similar analog board as the Disk ][.  But as I understand it, the Disk ][ used a microswitch for write protect.  While this (and trhe GS 5.25) uses what appears to be an optical sensor.  Based on what I saw in the instructions for adding a manual switch, the switch interrupts the orange and purple wires in the sensor circuit (the other two are brown and blue, presumably these are the power wires for the IR LED).  So as a test, could I just jumper the orange and purple wires at the connector?  I guess I could also verify i have power in the brown and plue wires as well.  Is that LED always powered on, or only when the drive attempts to write?

 

Any other ideas to test/fix this, short of installing a manual switch?

 

Thanks!

Online
Last seen: 7 min 5 sec ago
Joined: Jun 6 2020 - 10:50
Posts: 11
Well, I partially answered

Well, I partially answered some of my own questions.  I took the drive apart along with my IIgs 5.25 drive.  I can see about 1.2v across the brown and blue wires that power the IR LED.  So that means the LED is working and is on all the time, not just when the drive is working.  I took an old digital camera that can "see" infrared.  On both drives I can see the purple light being picked up by the camera from the IR LED.

 

So that leaves somethign gone wrong with the optical pick up/sensor.  I pulled the orange and purple pins out on the working IIgs drive.  When the LED and sensor are clear/can see each other, it measures around 4.4k or so on my DMM.  If i slide a disk in and block it, it goes to infinity.

 

I then pulled the orange and purple wires out of the connector.  When the LED and sensor are clear/see each other on that drive, my DMM display just flashes when Itry to read the resistance.  If I block the sensor, instead of going to infinity, it starts reading in the neighborhood of 5Meg.

 

I don't know enough about these senosrs to see if I can find a compatable one on Digikey/Mouser.  And even if I did, that leaves digging out the epoxy/glue used to hold it in.  Probably doable, if I could source the right part.  Are there any schematics or parts lists for either the //c drive or the IIgs 5.25 that show the optical sensor?  I keep coming accross Disk ][ schematics in my searches, but they used the mechanical switch.

 

If anyone has any other ideas or suggestions, I'm open to them.

Offline
Last seen: 17 hours 48 min ago
Joined: Mar 31 2020 - 19:55
Posts: 383
I need to look at a Disk //c

I need to look at a Disk //c analogue board to confirm, but on the UniDisk 5.25, you connect a switch between R12 and J29 on the analogue board. 

 

Alternatively, you can bridge pins 6 and 7 (iirc) on the 20-pin header,  which is common across all Disk ][ stuff. The //c analogue card will have the same connector on it. 

 

I'll try to find a schematic, but I doubt one eists for the Disk //c analogue card that will have a p/n or rating on the optical sensor. 

 

As far as I recall, the drive light should only be on when it is trying to access the disk. No other Disk II (or Apple floppy drive) product behaves where the LED is always on. Does the drive read disks?

 

I've seen a number of analogue cards where the write protect circuit was shorted. This often occurs by plugging or unplugging the drive when the system was still under power. I would suspect that, ere suspecting the sensor itself. 

 

https://www.applefritter.com/appleii-box/H084_2a_AppleIIDiskService2a.htm

 

 

DuoDisk-UniDisk-Analogue-Card-Chips.pdf

Online
Last seen: 7 min 5 sec ago
Joined: Jun 6 2020 - 10:50
Posts: 11
The analog board on the //c

The analog board on the //c is somewhat of a hybrid of the analog Disk ][ and UniDisk 5.25 (or what I was calling the IIgs drive).  It shares the same IC's  and (seemingly) same components as the Disk ][ analog card and neither has jumper wires on the PCB.  But while the Disk ][ analog card has an edge connector to run the wires to the motor control card, the UniDisk and //c drive use a 16 pin connector.  Technically, its a 20pin connector on the UniDisk, but 4 pins are not connected and the wiring looks exactly the same as the //c 16 pin connector.  I think its safe to assume the //c and UniDisk used the same IR LED and sensor based on this.

 

When I said the LED is always on, I was referring to the IR LED that shines through the floppy write protect slot.  Both the //c and UniDisk drives keep the IR LED energized constantly, not only at the time of checking if the floppy is protected.  The red activity LED only turns on when the drive is being accessed.  And the //c drive appears to work normally otherwise.

 

In this case, I don't think its the write protect circuit itself.  As I noted above, I pulled the orange and purple sensor wires out of the connector, and left the rest intact.  I then checked what the resistance was on the sensor with my DMM.  The sensor on the //c drive is not acting the same way as the sensor on the UniDisk.  This tests the sensor alone, and eliminates any circuitry that reads it.

 

When the sensor can see the IR LED, the UniDisk sensor (that is working) shows about 4.4k ohms of resistance.  On the //c drive, the meter display just flashes "0.L" (which means infinity/open).  But the flashing indicates for a brief second, its trying to read something, but can't and goes back to infinity/open.  It does this over and over.

 

When the sensor is blocked, the Unidisk goes to infinity/open.  On the //c drive, it ranges anywhere form 2.5M ohms to 10M ohms (I checked it 3 different times, got 3 different readings in that range).

 

So while the UniDisk sensor appears to be acting rationally, the //c sensor clearly is not.  The first link you posted shows the //c drive and you can see exactly what I've described.  There is one small error (at least compared to my whopping sample size of two drives, one //c, one UniDisk 5.25).  On both of my //c and UniDisk drives, the IR LED shines up from the bottom, and the sensor is on the top.  Opposite of what the drawing on that page indicates.  I confirmed this using a digital camera that can see IR LEDs as purple light in the picture.  I also confirmed that by checking the color of the wires that run to each (purple and orange to sensor, blue and brown to IR LED).

 

But this page confirms my theory that to enable writes, I need to either jumper/short the purple and orange wires, or add a switch to short them and open them as needed.  I highly doubt I will find a suitable sensor replacement without any kind of existing part number/specs/datasheet to go off of.  So this may be the only viable option at this point.  As much as I hate during permanent modifications, I guess a disk drive with a hole drilled in it and switch mounted is better than a disk drive that can't write at all.

Offline
Last seen: 17 hours 48 min ago
Joined: Mar 31 2020 - 19:55
Posts: 383
nick3092 wrote:The analog
nick3092 wrote:

The analog board on the //c is somewhat of a hybrid of the analog Disk ][ and UniDisk 5.25 (or what I was calling the IIgs drive).  It shares the same IC's  and (seemingly) same components as the Disk ][ analog card and neither has jumper wires on the PCB.  But while the Disk ][ analog card has an edge connector to run the wires to the motor control card, the UniDisk and //c driv

 

You can always jumper the wires without a switch if you want to look for a better solution, later. 

 

I'd straight swap you a UniDisk 5.25 for the Drive //c, even with its malfunction, if you want. I have some spare UniDIsk drives, but I cannot find any of my Disk //c drives, and I have a specific application for one. 

 

The UniDisk 5.25 will work perfectly well. My application is based on space constraints. I can likely service the Disk //c in the future and repair it if I ever need it to be r/w, which at present, I do not; and if I did, I would not need to worry about write protect, so I would not mutilate it. 

Online
Last seen: 7 min 5 sec ago
Joined: Jun 6 2020 - 10:50
Posts: 11
I very well may take you up

I very well may take you up on that trade, if you aren't in a hurry.

Offline
Last seen: 17 hours 48 min ago
Joined: Mar 31 2020 - 19:55
Posts: 383
nick3092 wrote:I very well
nick3092 wrote:

I very well may take you up on that trade, if you aren't in a hurry.

 

I'm in no particular hurry. 

Online
Last seen: 7 min 5 sec ago
Joined: Jun 6 2020 - 10:50
Posts: 11
Hmm, so I took a closer look

Hmm, so I took a closer look at the drive.  Looks like someone tampered with the SN74LS125AN.  Specifically, pin 10.  Which according to the Disk ][ schematics, has something to do with the write protect.  Looking at the top, it looks like the solder blob is not making contatct with the PCB.  It also looks like the trace maybe gone to R12.  But then on the other side, I see someone installed a bodge wire from pin 10 to R12 to make up for it.

 

 

So now I'm wondering if someone didn't mess something up by hotswapping, and then tried to fix it.  Looks like you can still get SN74LS125AN chips.  Maybe the next time I order from Digikey, I'll pick one up (along with a socket), and swap it out.

Offline
Last seen: 17 hours 48 min ago
Joined: Mar 31 2020 - 19:55
Posts: 383
Most likely, that someone did

Most likely, that someone did hot-swap it, or pluggd it into the wrong port. That's a particularly easy component to burn out, as you may have noticed on the chips PDF that I posted. 

Online
Last seen: 7 min 5 sec ago
Joined: Jun 6 2020 - 10:50
Posts: 11
The new IC showed up today,

The new IC showed up today, and I desoldered the other one. I think I found the real root cause. When whoever reworked this destroyed the pad and trace on the top for pin 10 and R12, they didn't realize there is also a trace under the IC from pin 10 to pin 2. I think because of the damage they did, that trace was no longer making contact to pin 10.

I installed the socket and then added a second bodge wire from pin 10 to pin 2. Put the new IC in, fired up the drive. Still read disks fine, so next I put a blank disk in and formatted it. Worked like a charm! Put a write protected disk in, it refused to write. So the drive is fully functional again.

As long as I had the analog board out, I recapped it for preventative maintenance. I'll probably do the same to the motor board before I case it back up as well. This means I'm not looking to trade the drive any more, sorry.

Appreciate the help in pointing me in the right direction!

Offline
Last seen: 1 week 4 days ago
Joined: Jun 27 2020 - 13:39
Posts: 3
Great work!

Awesome that you managed to fix the write protect issue. Since I need to replace one of the 74LS ICs on the Disk II controller, I want to ask you where do you buy these type of IC?Thanks.

Online
Last seen: 47 min 39 sec ago
Joined: Nov 7 2019 - 13:49
Posts: 43
l00pback wrote:Since I need
l00pback wrote:

Since I need to replace one of the 74LS ICs on the Disk II controller, I want to ask you where do you buy these type of IC?

Most of the 74LSxxx ICs are still in production and very common. All the usual (online) shops selling electronic components still have them, whatever is the most common in your country. Just make sure to order the right package (DIP variant with pins, not a more modern tiny SMD package :-) ).

Offline
Last seen: 17 hours 48 min ago
Joined: Mar 31 2020 - 19:55
Posts: 383
nick3092 wrote: The new IC
nick3092 wrote: The new IC showed up today, and I desoldered the other one. I think I found the real root cause. When whoever reworked this destroyed the pad and trace on the top for pin 10 and R12, they didn't realize there is also a trace under the IC from pin 10 to pin 2. I think because of the damage they did, that trace was no longer making contact to pin 10. I installed the socket and then added a second
Very good news there. I managed to find my Disk //c yesterday. Apparently, it was in a box with a couple non-Apple drives, where it did not belong.
Offline
Last seen: 1 week 4 days ago
Joined: Jun 27 2020 - 13:39
Posts: 3
Thanks for the reply
MacFly wrote:
l00pback wrote:

Since I need to replace one of the 74LS ICs on the Disk II controller, I want to ask you where do you buy these type of IC?

Most of the 74LSxxx ICs are still in production and very common. All the usual (online) shops selling electronic components still have them, whatever is the most common in your country. Just make sure to order

Well I meant stores in USA especially local ones (Washington DC area). Its funny to pay cents for IC and then 10x more for shipping.

Log in or register to post comments