Ultima II not working on SE/30?

4 posts / 0 new
Last post
CheshireNoir's picture
Offline
Last seen: 2 hours 15 min ago
Joined: Dec 28 2019 - 05:20
Posts: 90
Ultima II not working on SE/30?

Hey Folks,

Anyone been able to get a version of Ultima II that works on SE/30s?

The only version I have been able to find is a "booter" disk that happily boots up then locks up my Mac as soon as I click a menu.

 

I have a fond memory of this game on the Mac, and hoped to play it again on the first platform I played it on.

 

Cheers!

 

Chesh

Offline
Last seen: 6 hours 18 min ago
Joined: Mar 31 2020 - 19:55
Posts: 596
Hmm.... IDK if this works on

Hmm.... IDK if this works on models beyond the Plus and original SE. It is a 1985 release, with weord copy protections. 

 

You could try running it from a Sys 6 machine. I sincerely doubt that it will run on Sys 7. 

 

IMO, the Apple ][ version is the way to go. 

 

I suspect that the 030 trips it up somehow, as may the SE/30 ROM and memory map.  

 

Given your other issues with that SE/30, I do not want to offer any sort of diagnosis, as the system may have faults. 

CheshireNoir's picture
Offline
Last seen: 2 hours 15 min ago
Joined: Dec 28 2019 - 05:20
Posts: 90
It's a booter

Typical Origin of the time :-)

The disk is self booting. You can't actually run the disk from any OS. Yeah, dumb design, I know.

I'll see if I can get a Mac emulator to run it. If I go 8 Bit, I'm more likely to go C64. It was a reasonably good port.

 

Also my SE/30 has been behaving fine since I cleaned and lubed the FDD  :-)

You might be thinking of jamesleboulanger who was having all sorts of issues...

 

Cheers!

 

Chesh.

CheshireNoir's picture
Offline
Last seen: 2 hours 15 min ago
Joined: Dec 28 2019 - 05:20
Posts: 90
Quick followup (For anyone following in my footsteps)

I got Ultima II working in PCE Mac without issues. It wouldn't work under MiniVMac, but that may be a setting I missed.

Log in or register to post comments