anyone here play diablo 2 on battle.net?

5 posts / 0 new
Last post
Offline
Last seen: 1 month 3 weeks ago
Joined: Jan 19 2005 - 23:30
anyone here play diablo 2 on battle.net?

I have been playing for years, but never have i had so many problems with staying connected to the server. i cant figure it out, ive tried different computers, changeing wireless settings. i simply cant figure it out. i was wondering of others out there play this game and have similar problems as well... ive been on wireless the whole time no problems elsewhere though.....

madmax_2069's picture
Offline
Last seen: 7 years 7 months ago
Joined: Sep 24 2005 - 07:28
huh i do every once in a wile

huh i do every once in a wile, i havent played D2 in a long time i need to reinstall it and D1. D2 should play much better then when i had it installed with the stock cpu G3 266 and 196mb ram. and stock 2mb vram rage pro. cause that is the last time i played it is on the stock config.

Offline
Last seen: 1 month 3 weeks ago
Joined: Jan 19 2005 - 23:30
i cant imagine playing D2 on

i cant imagine playing D2 on a 266, my 500 seems to lag some w/ radeon 7000. i play almost all the time on my PC because its beefed. i wonder if its a problem with my cable provider. i never used to have this issue.

madmax_2069's picture
Offline
Last seen: 7 years 7 months ago
Joined: Sep 24 2005 - 07:28
it played real nice on the st

it played real nice on the stock config sept for a few spots like the cow world or places where there was a lot of people. but ive since that installed a R7k and a 120gb hdd, the 4mb vram upgrade on the onboard rage pro for a combined of 6mb vram,and the 466mhz G3 cpu and 448mb ram. so it should play a bit better

madmax_2069's picture
Offline
Last seen: 7 years 7 months ago
Joined: Sep 24 2005 - 07:28
man it play's sooo much bette

man it play's sooo much better than stock i get no lag almost. its fluid now

Log in or register to post comments