SDL Pom1

8 posts / 0 new
Last post
anarkavre's picture
Offline
Last seen: 3 years 2 months ago
Joined: Oct 18 2005 - 11:28
SDL Pom1

I started a project to port the Pom1 Apple 1 Emulator from Java to C. I'm using SDL, so it should work on most platforms. I'm going to put up a site for the project some time soon. Until then you can see an early screenshot here.

Tom Owad's picture
Online
Last seen: 44 min 54 sec ago
Joined: Dec 16 2003 - 15:14
That's great!

That's great! Please keep us informed of your progress.

anarkavre's picture
Offline
Last seen: 3 years 2 months ago
Joined: Oct 18 2005 - 11:28
Site Open

The site for the project is now open. You can view it here.

anarkavre's picture
Offline
Last seen: 3 years 2 months ago
Joined: Oct 18 2005 - 11:28
Just another update to inform

Just another update to inform you all of my progress. I implemented my own load and save routines for memory that work similar to the Java version. I'm going to add a configuration file so you can keep your preferenced settings. I also still need to figure out the BASIC problem. I registered for hosting of the project on SourceForge.net and I'm still waiting for confirmation.

anarkavre's picture
Offline
Last seen: 3 years 2 months ago
Joined: Oct 18 2005 - 11:28
The project has be moved to S

The project has be moved to SourceForge.net.
http://pom1.sourceforge.net/
http://sourceforge.net/projects/pom1/

Krest's picture
Offline
Last seen: 9 years 6 months ago
Joined: Sep 29 2004 - 12:39
Looks good so far. I can't wa

Looks good so far. I can't wait to test it myself. Smile

anarkavre's picture
Offline
Last seen: 3 years 2 months ago
Joined: Oct 18 2005 - 11:28
I finally figured out the pro

I finally figured out the problem with BASIC not working. The problem was a typo on my part in the (zp),y function, it was an equal sign instead of a plus sign. I feel like an idiot now, but it's a common mistake. Blum 3 Now I can finish a few more things and get the first release out in the next day or so.

anarkavre's picture
Offline
Last seen: 3 years 2 months ago
Joined: Oct 18 2005 - 11:28
algogocom made a comment, but

algogocom made a comment, but it's not showing. Weird, when I posted this it still showed 7 replies.

Log in or register to post comments