Xubuntu on Wallstreet, no sound.

15 posts / 0 new
Last post
Offline
Last seen: 9 months 2 weeks ago
Joined: Dec 16 2005 - 12:05
Xubuntu on Wallstreet, no sound.

After getting fed up with debian, I decided to give Ubuntu a try. Knowing that Ubuntu, with Gnome, would probably take too many resources, and bring the little 233MHz G3 to a halt, I decided to go with Xubuntu, Ubuntu with the lightweight XFCE4 GUI. It runs very well, and is snappy. It sleeps when I shut the lid, there are no networking problems, and even with several programs open doesn't slow down much.

The main problem I'm having is with sound. Simply put, it doesn't work. Is there a way to look through a device manager or run some kind of setup program?

I know some of you guys here run Ubuntu, so I thought you may be able to help. Smile

(I also have a post on the UbuntuForums)

Jon
Jon's picture
Offline
Last seen: 6 years 11 months ago
Joined: Dec 20 2003 - 10:38
First question: does sound wo

First question: does sound work in OS X? ax0n has a WallStreet that has a partially bad DC/sound board. No sound, but the power is fine.

Offline
Last seen: 9 months 2 weeks ago
Joined: Dec 16 2005 - 12:05
Well, I don't use OS X on it

Well, I don't use OS X on it (yet! I plan to install panther tomorrow) but sound in OS 9 works fine.

Offline
Last seen: 4 years 10 months ago
Joined: Dec 20 2003 - 10:38
inverse help

I would love to be the hero and post a suggestion but as you may know my attempt at Ubuntu Dapper Drake on the Wallstreet was disasterous. The installer hangs when running its scripts from the ramdisk image and the whole thing comes to a halt. There was no useful info on the UbuntuForums. All the posts just say "after the installer is finished..."

Hokusai's picture
Offline
Last seen: 5 months 4 weeks ago
Joined: Dec 20 2003 - 10:38
Hmm...

I ran into the same problems when installing Xubuntu on my Wallstreet. Mind you, the ethernet didn't even work on my although it seems to work on yours.

You have to tell it to manually load the drivers for the onboard sound. For this you have to go to the terminal. Do 'sudo vi /etc/modules' and then add 'snd-powermac' to it and save. That should work if I wrote it down right.

Offline
Last seen: 9 months 2 weeks ago
Joined: Dec 16 2005 - 12:05
Ok, I'll try that now :)

Ok, I'll try that now Smile

EDIT - Well, snd-powermac is already there, along with mesh, bmac, and apm_emu...

Anything else I might be able to add?

Offline
Last seen: 9 months 2 weeks ago
Joined: Dec 16 2005 - 12:05
I've run "lsmod | grep snd",

I've run "lsmod | grep snd", "/sbin/modinfo snd-powermac", and "sudo modprobe snd-powermac" (as suggested on teh UbuntuForums). lsmod | grep sound returns nothing, and the other two return something about not being able to find "/lib/modules/2.6.17.11/modules.deb"

EDIT - AHA! Turns out I improperly installed the kernel, its a tar.bz2. I think it just needs to be a tar. Any idea how I can decompress it halfway?

Eudimorphodon's picture
Offline
Last seen: 1 week 5 days ago
Joined: Dec 21 2003 - 14:14
lsmod

Have you run "lsmod" and seen if the module is actually loaded? If you don't see it try "modprobe snd-powermac" and see if it loads. (Type "dmesg" after doing so to see if inserting the module generated any interesting kernel errors). If the module's loaded, try running alsamixer. Back in the day the ALSA sound drivers would often initially set themselves up with audio muted, and sometimes the non-ALSA mixers wouldn't be able to fix it.

Last time I ran Linux on my iMac I came to the conclusion that the snd-powermac driver (and the Macintosh sound hardware itself) sucked stale cheetoes, but that's another problem.

--Peace

EDIT: Oh, never mind, you've already lsmodded.

So why are you messing with tar files for the kernel? You should just be able to apt-get a perfectly usable kernel package and matching headers. Compiling your own kernel, particularly on PPC machines, is generally sort of a waste of time.

Offline
Last seen: 9 months 2 weeks ago
Joined: Dec 16 2005 - 12:05
Well, I already have the kern

Well, I already have the kernel, I'm not compiling my own, I just improperly implemented the one I downloaded into the wallstreet.

What I did is download the fine, the un tar + in bzip2 it, then, being left with just a folder, I opened it, took out the kernel of the kernel, and used that.

It works fine, but totally left out the modules folder.

Jon
Jon's picture
Offline
Last seen: 6 years 11 months ago
Joined: Dec 20 2003 - 10:38
And why, though? As was poin

And why, though? As was pointed out, you just apt-get install linux or apt-get upgrade linux or you just let Synaptic or the auto-update system take care of it. There isn't much need to manually deal with kernel tarballs on PPC.

Offline
Last seen: 9 months 2 weeks ago
Joined: Dec 16 2005 - 12:05
That may be true, but, I need

That may be true, but, I need to get the kernel into BootX. Otherwise its totally useless.

Jon
Jon's picture
Offline
Last seen: 6 years 11 months ago
Joined: Dec 20 2003 - 10:38
It's entirely possible to jus

It's entirely possible to just copy the kernel from your Ubuntu install right to your HFS Mac OS partition. Just let the updates do their thing, then mount the HFS partition and copy the files over. Then you reboot and select the new files in BootX. There's no need to deal with separate tarballs of the kernel. If you have Ubuntu installed, you have all the files you need already.

Offline
Last seen: 9 months 2 weeks ago
Joined: Dec 16 2005 - 12:05
Ok, that sounds like a good i

Ok, that sounds like a good idea. How would I mount the HFS partition, and where is the kernel?

EDIT - Actually, I think that maybe getting this to work in BootX is the best way to go. So far, I can't get BootX to select it.

Offline
Last seen: 4 years 10 months ago
Joined: Dec 20 2003 - 10:38
I'm kind of curious as to why

I'm kind of curious as to why I'm the only person with a stock-standard 6.06-for-Mac CD but can't actually get it to even install, let alone have sound issues.

Should I be using a different ramdisk image to the one that's on the CD?

Sorry to change topics somewhat but this thread seems like the best place to ask.

Offline
Last seen: 9 months 2 weeks ago
Joined: Dec 16 2005 - 12:05
Is it a "live" CD or "alterna

Is it a "live" CD or "alternate" CD? I kept trying to use live ones, and the system was using so much power trying to boot it, that it never actually booted, just crashed. An alternate install worked.

I used the kernel and ramdisk that were included for the install, but then switched to the 2.6.17.11 kernel, which works fine.

Log in or register to post comments