Apple II Power Problem

4 posts / 0 new
Last post
Offline
Last seen: 16 years 7 months ago
Joined: Dec 25 2007 - 14:13
Posts: 2
Apple II Power Problem

I have an Apple IIe enhanced of the 1987/87 era (according to the date printed on the motherboard). It's a lovely machine, and I would like to get it back up and working again. Unfortunately, when I turn it on it, it initially displays a pattern on the screen (I'm using a TV) though with no beep, and then fails to display anything else. After this brief display, the internal red and external green LED lights dim.

I also have two 1984 era Apple IIes, which work fine on startup. What could be happening with my Apple IIe enhanced and could a replacement part from the the older Apple IIs fix it?

Offline
Last seen: 8 years 8 months ago
Joined: Apr 10 2006 - 20:01
Posts: 1013
You might try a couple of rea

You might try a couple of really easy things first: swap in a good power supply, and push down on all the socketed components. See if that helps the situation any.

Offline
Last seen: 16 years 7 months ago
Joined: Dec 25 2007 - 14:13
Posts: 2
Power Supply

The other power supplies I have are from the earlier Apple IIs. But, I notice these look smaller than the Apple IIe enhanced power supply. Would the former work in place of the latter?

Offline
Last seen: 8 years 8 months ago
Joined: Apr 10 2006 - 20:01
Posts: 1013
Yes, they're all interchangea

Yes, they're all interchangeable. The IIgs made a change to the connector, but otherwise, mix-n-match.

Log in or register to post comments