Screwed up TiBook

3 posts / 0 new
Last post
GEOS's picture
Offline
Last seen: 4 months 3 weeks ago
Joined: Dec 20 2003 - 10:38
Screwed up TiBook

I have recently acquired an 867MHz Titanium Powerbook G4. Since having it the past few days, I've learned this thing has got a huge set if problems. Most of these I think can be attributed to small bits of corrosion on the logic board which I've discovered. The first issue I encountered was the computer always booting up into "Startup Manager" to select a boot drive. Even without holding down the Option key this happens EVERY time I power on or restart. I also discovered that holding down "T" would not get it to boot into target disk mode, Instead, "Command" would boot into TDM.... weird. I also noticed the problems while trying to do a fresh install of OS X. During installs of both Leopard and Tiger, the installation would fail at different times. This lead me to think there could be a memory problem. I removed the RAM and tested it in an iBook and both sticks worked great and had no visible problems. Upon further inspection, I noticed some corrosion around where the RAM sockets meet the logic board and near where the keyboard connects. Its also worth mentioning that once I did get an OS installed, I frequently get application crashes and kernel panics. Unless I'm missing something else, I think this can be all attributed to the corrosion on the board. Does anyone have any suggestions on the best way to clean it off without damaging circuits? Fortunately, the underside of the board looks good, its all on the top (which is also the hardest part to access). Here are the things I've tried:

-PRAM rest
-Open Firmware Reset-NVRAM
-tried one stick of RAM at a time in either top or bottom slot (corrosion on both where they meet the motherboard)
-scraped as much corrosion off as I could with a toothpick

Dr. Webster's picture
Offline
Last seen: 3 hours 28 min ago
Joined: Dec 19 2003 - 17:34
Corrosion on the top of the b

Corrosion on the top of the board suggests liquid was spilled on the unit at some point. That may also explain the odd keyboard behavior, as liquid could have gotten between the membranes and caused some damage.

I'm not certain that removing the surface corrosion would help, but cotton swabs at isopropyl alcohol would be the safest combination to use on the board. IPA dries quickly and without residue.

GEOS's picture
Offline
Last seen: 4 months 3 weeks ago
Joined: Dec 20 2003 - 10:38
I went ahead and got a lot of

I went ahead and got a lot of the corrosion off with a isopropyl and cotton, as well as a very soft bristled toothbrush. Seems to be a little more stable now, but it still boots into Startup Manager every time, even when the keyboard is disconnected. Is there a way to bypass that somehow? Perhaps even holding some other key combo during startup? It just sucks cuz it prolongs startup by a ton having to wait for it to go through that process every time.

Log in or register to post comments