PowerBook Pismo G3 Problems

5 posts / 0 new
Last post
mudogramx's picture
Offline
Last seen: 16 years 5 months ago
Joined: Jun 21 2005 - 13:16
Posts: 34
PowerBook Pismo G3 Problems

Hey everyone,

I bought a PowerBook Pismo G3 off of eBay. The laptop did not have a hard drive, and also had a dead battery. I purchased and replaced them. Now that everything is plugged in and ready to go, nothing happens when I push the power button. I made sure the CPU card was properly seated and that everything was nice and tight. Is it the PRAM? I am out of ideas and would like some help if possible.

Thanks

coius's picture
Offline
Last seen: 8 years 10 months ago
Joined: Aug 25 2004 - 13:56
Posts: 1975
most likely the PRAM Battery

Let it sit plugged in over night as the PRAM battery may be dead. The Pismo requires that the PRAM battery be charged to boot

mudogramx's picture
Offline
Last seen: 16 years 5 months ago
Joined: Jun 21 2005 - 13:16
Posts: 34
Great to hear

I was hoping that was all it was. I am new to Pbook G3s and didn't realize the PRAM battery was required for booting. Thanks!

mudogramx's picture
Offline
Last seen: 16 years 5 months ago
Joined: Jun 21 2005 - 13:16
Posts: 34
It was the PRAM

The PRAM was charged but the connections between the button cells were bad. I checked the PRAM battery with a voltage meter and got the correct voltage. I took the sheath off of the battery and fixed the connections. Voila! The PowerBook is running once again.

Jon
Jon's picture
Offline
Last seen: 11 years 8 months ago
Joined: Dec 20 2003 - 10:38
Posts: 2804
Cool! That's gonna have the

Cool! That's gonna have the be put around as a last resort before replacing the PRAM battery. I'll have to mention it to ax0n if he doesn;t catch this thread on his own. His Wallstreet has had similar problems in the past, but may already be fixed with a new PRAM

Log in or register to post comments