Can't get YDL 4.0.1 to work with ATI Mach64 card

2 posts / 0 new
Last post
Offline
Last seen: 17 years 1 month ago
Joined: Jun 26 2005 - 09:06
Posts: 15
Can't get YDL 4.0.1 to work with ATI Mach64 card

I'm trying to get Yellow Dog Linux 4.0.1 to work on a Storm 200DP Mac with 256mb RAM and a ATI Mach64 4mb PCI videocard (pulled from a 9500), but I have problems with the videocard.

YDL will only launch the installer (text) when the ramdisk size is set to '65000' instead of standard '8169'

The installer won't run in graphic mode; I'll end up with a black screen with a small dot in the upper-left corner or an error with a reboot.
Text install does work, but at the end of the installing processor (message says 'Installing bootmanger) the lines 'ddcprobe returned bogus' come true the installer, and I'll end in a reboot.

But I can start the installed Linux systems, except when I try to launch startx it stops with the error: 'No screens available'.

Using "/usr/X11R6/bin/XFree86 -configure" and using that config I still get the same error message.

All sites I have visited with problems consulting Mac's with Mach64 card says that you have to use "xconfigure", but it does not seems to be installed with Yellow Dog Linux 4.0.1...

Adding 'video=atyfb:vmode:17' to the kernel option gives me a better resolution on boot, but X still won't run.

Anyone has got an idea???

Offline
Last seen: 17 years 4 months ago
Joined: Sep 2 2005 - 05:23
Posts: 9
Thats quite strange, because

Thats quite strange, because those Match 64 work without problems with the ati driver, try editing XF86Config, and selecting some sane resolutions/color depth and driver "ati" in the section Device. That *should* solve the probelm

Log in or register to post comments