Apple II+ not posting

8 posts / 0 new
Last post
Offline
Last seen: 1 year 11 months ago
Joined: Nov 24 2013 - 13:23
Posts: 226
Apple II+ not posting

I decided to go after the keyboard issue in my II+ again. However now when I power it on, I get a screen full of this:

??@@??@@??@@??@@ etc.. with the @@s in reverse video. If I cycle the power, sometimes I get flashing > or other symbols at random spots. I thought maybe CPU, so changed that to known good, but no dice there. I know the ROMs are good and am confident the RAMs are ok... where do I begin on this one? Smile

speedyG's picture
Offline
Last seen: 5 years 1 month ago
Joined: Nov 16 2011 - 07:45
Posts: 2493
Re: Apple II+ not posting

Hello falter,

how about starting first to think logic and making diagnosis by eliminating intact stages ?
if the input starts running ( by entering chars ) after power up and bootup process the problem is to be located
in the communication of the keyboard ( otherwise the keyboard could not enter any chars if
no key is pressed ?.... ) in normal state the computer would boot and then wait for the user
to enter chars ... correct ???
then next step would be to consult the "Apple II circuit description" for the lines that are responsible for that communication correct ? So why not examining the Fig. C-22 at page 219 of the book....

So viewing the shematic there following parts are related to the keyboard communication:
Pin 31 of the decoderchip ( strobe delay ) and the capacitor C2.
Pin 16 of the decoder chip ( Dara strobe output ) and the following gates of 74LS00 at chip location B3.
the capacitor between Pin 1 and Pin 2 of the decoder chip ( C5 / 47 pF )
the resistor between Pin 2 and Pin 3 of the decoder chip ( R1 / 51 k )
tjhe repeat key coneccted to pin 4 of the decoder chip getting it´s signal from the pin 4 of the 555 chip at location B2.

and if you get the screen full of chars - before you see the Apple II at top of the screen -
how about thinking about the fact, that the computer crashes before even finishing with the bootup process.....
does that really have to do something with the keyboard or do you rather more face an issue with damaged adressing line or dataline or damaged RAM chip ????
So how about examining and measuring this possible sources of trouble ???
and how about using own thoughts and brain ?
sincerely speedyG

Offline
Last seen: 1 year 11 months ago
Joined: Nov 24 2013 - 13:23
Posts: 226
Re: Apple II+ not posting

Speedy

On this particular system, it has always produced screen garbage if keyboard was not connected. I don't know why. Please remember I am a novice at this and reading and understanding schematics are still new to me. It was working, when it broke, I went back to the last thing I changed to see if it was that. Seems logical enough to me to start there. Obviously it wasn't that.

My problem is that I don't know Apple IIs well enough to understand how the whole boot process works. On some of my vintage machines, no keyboard = no boot. Certain types of garbage screen mean certain things. I was just looking to see if the particular output in this garbage screen contained a clue on where to look.

speedyG's picture
Offline
Last seen: 5 years 1 month ago
Joined: Nov 16 2011 - 07:45
Posts: 2493
Re: Apple II+ not posting

hello falter,
though i recognize you of beeing a novice, as many others joining this board too....
i´d expect not every time explaining topics from very basic...how would you react if your granddad would expect you to chew his food upfront ? At least i expect newbies here not to be that lazy - not even to view earlier threads related to the topic..... we all share our time here and experts have also limited time not to repeat again and again same stuff that has been chewed up dozends of times here ..... thats waste of time.
Do you really expect us to waste our time ( and its same precious as yours ! ), just because your to lasy to review previous threads ?
Just if your too lazy to view all threads about that topic, how about at least viewing with the track function
( click to user name => click at track => scroll along to threads related to this topic => jump to the thread and search in the poastings and explenations ..... )
You´ll find at least 2 threads in which bootup pptocess have been explained in very detail !
And you´ll find at least 5 or 6 threads covering up this kind of problem !
At birth you´ve got the precious gift of a brain.... why not use it ?
speedyG

Offline
Last seen: 1 year 11 months ago
Joined: Nov 24 2013 - 13:23
Posts: 226
Re: Apple II+ not posting

I did a lot of googling, actually, before posting here. I'm sure on any given topic, the same items will be covered multiple times regardless. Often same symptoms can be different problems. Believe me, I tried a whole host of suggestions here and on various forums before posting. Sometimes we miss things. As it turned out my problem was the 20 ROM and a pin that was bent ever so slightly out of place.

I appreciate and regret I have annoyed you. I could do without the insults though. I will not post here again.

Offline
Last seen: 1 month 4 weeks ago
Joined: Oct 9 2013 - 19:33
Posts: 372
Re: Apple II+ not posting

Falter, don't take it personally. Speedy seems extremely knowledgeable, just has trouble speaking politely to others sometimes Wink . I have learned a great deal from his posts and he is very generous when it comes to sharing the information he has. I chalk much of it up to the language barrier since English is his second language(German is his first) and the rest to simple cultural differences and mannerisms.
This is in NO WAY a slight against speedy, merely the personal observations/opinions of someone who has been lurking here far longer than posting here. I hate to see anyone leave, I am sure we all have something to contribute.
Zan

Offline
Last seen: 1 year 11 months ago
Joined: Nov 24 2013 - 13:23
Posts: 226
Re: Apple II+ not posting

Thanks Zan.

I very much appreciate where speedy has helped me and have tried my best to convey that. I appreciate all help I get and try to reciprocate when I can. The 'search first' thing though has always irked me a bit. If you don't know what you're searching for, can't put the correct search terms.. it's very hard to find what you're looking for. For example when I googled Apple II boot sequence I got a lot of references to DOS 3.3. I even tried googling the exact pattern I was getting.. the ??@@ .. no dice there.

I appreciate speed's help.. I just wish he wouldn't assume I'm being lazy. I actually prefer to solve this stuff myself (more pride in it that way), but sometimes you don't really know where to begin.

speedyG's picture
Offline
Last seen: 5 years 1 month ago
Joined: Nov 16 2011 - 07:45
Posts: 2493
Re: Apple II+ not posting

Hallo falter,
i don´t want to insult you, if i did, i appologize.
But in fact, if i would would take time to seek, i can list you as claimed above
- several threads and postings here just as claimed. I just expect that newbies
before starting a new thread with a problem that has been solved dozends of times
to first search the old postings and threads and only if they really don´t find answer
to start a new thread.
And of course there is no reason to leave....
if really a new problem raises up we gladly will assist in the task of troubleshooting the problem.
sincerely speedyG

Log in or register to post comments