Fixing Dove MacSnap SCSI Adapter for Mac 128k

5 posts / 0 new
Last post
Offline
Last seen: 3 months 37 min ago
Joined: Jan 19 2014 - 15:25
Posts: 60
Fixing Dove MacSnap SCSI Adapter for Mac 128k

Hello,
I recently acquired a Dove MacSnap card, which allows a SCSI port to be added to a Mac 128k. This board plugs into both ROM slots and provides a port for the SCSI cable. However, one of the pins that connects to the ROMs is missing, as well as two that connect to the SCSI-out cable. Does anyone know how I could repair something this delicate?

I can post pictures if that helps.

Offline
Last seen: 4 months 3 weeks ago
Joined: Oct 9 2013 - 19:33
Posts: 371
Re: Fixing Dove MacSnap SCSI Adapter for Mac 128k

Post a picture please.
Thanks!
Zan

Offline
Last seen: 3 months 37 min ago
Joined: Jan 19 2014 - 15:25
Posts: 60
Re: Fixing Dove MacSnap SCSI Adapter for Mac 128k

As requested, here's some pictures:
imgur.com/a/dRoiU

Dog Cow's picture
Offline
Last seen: 1 month 3 weeks ago
Joined: Dec 11 2008 - 16:26
Posts: 555
Re: Fixing Dove MacSnap SCSI Adapter for Mac 128k

One pin for the ribbon cable is supposed to be missing. That's to key the ribbon cable so you can't plug it in backwards. But I see you have 2 pins missing, so that additional pin may be a problem.

Offline
Last seen: 1 year 3 months ago
Joined: Feb 18 2015 - 14:40
Posts: 24
Re: Fixing Dove MacSnap SCSI Adapter for Mac 128k

It looks like the broken pin is important. The missing pin is most likely ground but the broken pin could be I/O or Data 0

Pinout Diagram

Log in or register to post comments