TL866II-Plus and 74LS51

14 posts / 0 new
Last post
Offline
Last seen: 1 day 7 hours ago
Joined: Aug 4 2015 - 14:30
Posts: 144
TL866II-Plus and 74LS51

I have noticed that a 74LS51 (location C13 on a A2 board) always fails when testing with the TL886II-Plus logic IC test function.

Even if I take one from a working A2 board.

I am using the lastest software version 11.60.

Can anyone here try the same and see what happens?

 

Offline
Last seen: 6 hours 20 min ago
Joined: Apr 26 2016 - 08:36
Posts: 455
I found similar

I found similar irregularities with the original TL866.

Ended up getting rid of it.

 

Offline
Last seen: 4 hours 17 min ago
Joined: Jul 5 2018 - 09:44
Posts: 1337
I've had pretty good results

I've had pretty good results with my original TL866.  However, I don't use the Windows software (don't have Windows), I use an open source one.  Also I've never used the chip testing features, I have only used it to program EPROMs, 2716 to 27512.

 

DDE
Offline
Last seen: 1 week 2 days ago
Joined: Aug 4 2020 - 21:06
Posts: 14
TL866

Hi, what software do you use and which OS?

Thanks,

DDE

Offline
Last seen: 6 hours 20 min ago
Joined: Apr 26 2016 - 08:36
Posts: 455
softwarejanitor wrote:I've
softwarejanitor wrote:

I've had pretty good results with my original TL866.  However, I don't use the Windows software (don't have Windows), I use an open source one.  Also I've never used the chip testing features, I have only used it to program EPROMs, 2716 to 27512.

 

The TL866 (and the TL866-II) aren't capable of burning 2716s.  They can't do 25V.

How are you doing it?  Or are you finding 21V 2716s?  They're pretty hard to come by.

 

 

Offline
Last seen: 4 hours 17 min ago
Joined: Jul 5 2018 - 09:44
Posts: 1337
I've burned quite a few 2716s

I've burned quite a few 2716s, from a couple of makers, ST mostly though.

 

I run Linux and I use an Open Source programming utility.  I don't know if that makes a difference.

 

 

Offline
Last seen: 2 months 1 week ago
Joined: May 27 2013 - 13:01
Posts: 849
Use 27c16 or 27c32. Both need

Use 27c16 or 27c32. Both need about 12 volts. Problem solved.

Offline
Last seen: 22 hours 55 min ago
Joined: Apr 9 2022 - 17:05
Posts: 19
I was having trouble with

I was having trouble with vertical sync on the Apple II and Monitor III I just acquired, so I tested this chip with my TL866II-Plus and I had exactly the same result. The chip worked fine on a breadboard though. So yeah, it's definitely not just you.

 

As far as burning EPROMs, yes, this programmer only goes up to 18 volts, but usually that works fine anyway, especially if you burn it repeatedly a few times in a row.

There's also this very promising-looking mod: https://www.eevblog.com/forum/blog/eevblog-411-minipro-tl866-universal-programmer-review/msg3946009/#msg3946009

that I plan to do if my pray-and-burn-it-again method starts to fail.

 

Offline
Last seen: 1 day 7 hours ago
Joined: Aug 4 2015 - 14:30
Posts: 144
Retro Chip Tester Pro
bradleyb wrote:

I was having trouble with vertical sync on the Apple II and Monitor III I just acquired, so I tested this chip with my TL866II-Plus and I had exactly the same result. The chip worked fine on a breadboard though. So yeah, it's definitely not just you.

 

I have since aquired the Retro Chip Tester Pro and it can test the 74LS51 just fine.

Offline
Last seen: 6 months 2 days ago
Joined: Feb 18 2020 - 16:59
Posts: 39
Oops

[Edited to add: Oops! I didn't catch that this was an old thread. Anyway...]

 

Have you also updated the firmware in the TL866II?

Are there other types of chips that do test correctly on your 866?

I'm not sure how the factory-supplied software works, but with the open-source MiniPro software that we Mac folks have to use, all of the tests (and expected results) for the various chips are in a couple of xml files. If that's the same with you, you might be able to check to see if there's a bug in the test script itself--and fix it if so.

Offline
Last seen: 1 day 7 hours ago
Joined: Aug 4 2015 - 14:30
Posts: 144
The newest software version works

I was using the newest firmware and software version at the time.

I just looked and there was a newer software version 11.90.

It now has Logic options 7451 and 74LS51, before there was only option 7451.

With most 74LS ICs there is only the 74### without LS and they work fine.

But the new 74LS51 option tests the 74LS51 chip fine.

 

Offline
Last seen: 22 hours 55 min ago
Joined: Apr 9 2022 - 17:05
Posts: 19
bradleyb wrote:I was having
bradleyb wrote:

I was having trouble with vertical sync on the Apple II and Monitor III I just acquired, so I tested this chip with my TL866II-Plus and I had exactly the same result. The chip worked fine on a breadboard though. So yeah, it's definitely not just you.

 

As far as burning EPROMs, yes, this programmer only goes up to 18 volts, but usually that works fine anyway, especially if you burn it repeatedly a few times in a row. There's also this very promising-looking mod: https://www.eevblog.com/forum/blog/eevblog-411-minipro-tl866-universal-programmer-review/msg3946009/#msg3946009 that I plan to do if my pray-and-burn-it-again method starts to fail.

 

I had to burn some MM2758 EPROMs recently and started trying this repeat burn method.

Firstly, the 2758 isn't supported so I repeat the data twice to get a 2048 byte file, and tell the programmer its an M2716.

It worked but it was taking upwards of a dozen repeated burns to get it to stick.

 

I did the linked modification to my programmer, just adding a 6.2K resistor and a jumper, and it worked flawlessly on the first try. Pretty great!

 

Also, as for the 74LS51 issue, I finally realized the whole reason this was an issue in the first place wasn't some subtle electrical difference, it's that the 74LS51 actually implements different logic from the original 7451 and 74S51. So it can't be used as a substitution without careful attention to the circuit. Specifically, if it leaves pins 11 and 12 unconnected or ties them high, you should be okay. If it grounds them or does anything else you'll have to make modifications.

 

 

MacFly's picture
Offline
Last seen: 2 hours 55 min ago
Joined: Nov 7 2019 - 13:49
Posts: 230
bradleyb wrote:Also, as for
bradleyb wrote:Also, as for the 74LS51 issue, I finally realized the whole reason this was an issue in the first place wasn't some subtle electrical difference, it's that the 74LS51 actually implements different logic from the original 7451 and 74S51. So it can't be used as a substitution without careful attention to the circuit.

 

That's a really interesting case. I can't remember having seen this before, where an LS variant indeed differs in logic and pinout to the non-LS variants of the same SN74xx. But the datasheet of the SN74x51 family indeed shows the differences. Interesting...

Offline
Last seen: 2 months 6 days ago
Joined: Apr 17 2022 - 12:26
Posts: 65
very interesting indeed And

very interesting indeed

 

And so the TL886 was right :) 

Log in or register to post comments