//c Disk (A2M4050) LED

5 posts / 0 new
Last post
telengard's picture
Offline
Last seen: 2 years 3 months ago
Joined: Feb 24 2014 - 12:40
Posts: 5
//c Disk (A2M4050) LED

I have one of these and noticed that the LED was not working.  Taking it apart there was no LED in the bezel.  I think this may have had a //c internal drive transplanted into this case.

I tried adding an LED as well as the appropriate cable and header (with the correct pinout after watching a teardown video) and it doesn't light up.

I'm using off the shelf LEDs, do these units use special ones?   Is there any firmware in these that might not be utilizing the LED?  Was surprised it didn't just work.   :(

Any ideas/help would be appreciated... not a big deal, but now that I have it apart I'd like it to work if I can.

Offline
Last seen: 2 years 3 months ago
Joined: Jul 31 2020 - 23:22
Posts: 21
My IIc internal Disk Drive

My IIc internal Disk Drive also had a LED tho it was not used because case dosnt have LED window.

My thoughts are that with modern LEDs you may need a resistor depending on the power output of the Disk LED circuit, my guess is between 3v to 5v, so you could try adding a 10 ohms resistor to the positive leg, if that doesnt work swap it for a 390 ohms resistor and so on, try the LED on a simple circuit first before using it on the IIc, it may be burned if you didnt used resistor on your first try.

Offline
Last seen: 2 hours 28 min ago
Joined: Feb 27 2021 - 18:59
Posts: 484
So...

LEDs have been controlled by current (not voltage) since they were invented. All devices that use LEDs have resistors (or their equivalent) to control the current and thereby control brightness.

The drive activity LEDs in Apple floppy drives are connected to +5V through a 330 ohm resistor and the other side is connected to /ENBL on the drive. When the host pulls /ENBL low to access the drive, the LED is driven with (5 - Vf) / 330 amperes. Forward voltage drop varies with LED type, but most red or green LEDs have a drop somewhere around 2V, so they will be driven with 9 mA. This calculation assumes negligible source impedance of the /ENBL output; in reality the drive current is less.

Note that blue or white LEDs have much higher Vf and won't light up in this circuit. If you have a red or green LED and it doesn't work, try testing it with a digital multimeter set to diode mode. Many DMMs can light red or green LEDs (although not blue or white LEDs). Make sure you connect it to the drive circuit in the proper direction (cathode towards /ENBL, anode towards +5V) or it won't light. And verify that the drive works—the LED is only active when the host accesses the drive.

Offline
Last seen: 1 day 8 hours ago
Joined: Apr 26 2016 - 08:36
Posts: 678
Also, check the polarity of

Also, check the polarity of the LED an make sure you did not connect it backwards.

 

telengard's picture
Offline
Last seen: 2 years 3 months ago
Joined: Feb 24 2014 - 12:40
Posts: 5
Thanks everyone for the

Thanks everyone for the feedback.  I did test the LED in a circuit with a 9v battery and resistor.  I also verified the orientation of the LED.  Drive does work too.

There is a small 2 pin connector on this particular drive for connecting the LED which is what I'm using.  I haven't been able to find a schematic for this particular board so I can't verify which side is /ENBL, etc.  I watched a teardown and from what I could tell, the anode connected to the left hand side pin.  In the video below it looks like the red wire is on the left hand side.

https://youtu.be/_hy4cp0VLUA?t=531

From the sounds of it though, I don't need an inline resistor, should be on the board.

 

Log in or register to post comments