ProDOS ROM-Card issue

4 posts / 0 new
Last post
Offline
Last seen: 1 year 10 months ago
Joined: Jun 22 2019 - 09:48
Posts: 41
ProDOS ROM-Card issue

I have assembled a couple of the ProDOS ROM-Card (by Terence J. Boldt) but it refuses to boot all the way to the bitsy boot menu amd it goes into the monitor when the Apple ProDOS 8 V2.4.2 screen has come up. Have tried go re-program the EPROM (no difference) and tested different slots and with a couple of Apple II's (same issue).

 

Chips have been tested as well even though they are brand new.

 

Anybody who have had some issues with these or have a suggestion?

 

Firmware image (the image with firmware and games etc.) comes from the Github project page.

 

TIA!

CVT
CVT's picture
Offline
Last seen: 30 min 28 sec ago
Joined: Aug 9 2022 - 00:48
Posts: 997
What is the version of your

What is the version of your card? Terence recently modified the card and the firmware, where he moved the assembly code from the end to the beginning of the ROM image. Old v2.5 cards are not compatible with the new firmware and vice versa. I already wrote a lot about this in this bulgarian forum, just right-click and translate to English: click!

Online
Last seen: 28 min 56 sec ago
Joined: Jun 29 2018 - 16:55
Posts: 579
I had a similar issue with my

I had a similar issue with my II plus and this card, the update to the firmware about a month ago sorted it for me. 

Offline
Last seen: 3 hours 7 min ago
Joined: Jul 5 2018 - 09:44
Posts: 2571
Which version of the PCB are

Which version of the PCB are you using?  I've built two so far using the v4.0 board and the updated firmware from the web site and both cards work for me.

 

Log in or register to post comments