MacEffects Apple IIe Keyboard LED issue

14 posts / 0 new
Last post
clockchip's picture
Offline
Last seen: 2 months 5 days ago
Joined: May 23 2018 - 16:33
Posts: 26
MacEffects Apple IIe Keyboard LED issue

Hi everybody,

is it normal that the MacEffects Apple IIe keyboard has so little brightness (I don't even see it turned on).

Can anyone confirm this who also has this keyboard, or do I have a defective keyboard. (maybe they soldered the wrong resistor on the board)?

regards

Clockchip

 

Offline
Last seen: 2 months 2 weeks ago
Joined: Jul 5 2018 - 09:44
Posts: 2587
Do you have a link to that

Do you have a link to that keyboard?  I wasn't aware anyone was making a new keyboard for a //e.

 

 

-- Edit --  Must be new.  I googled it and it says "picture coming soon" and it isn't showng on their store yet.

 

 

Offline
Last seen: 11 hours 30 min ago
Joined: Jun 6 2020 - 10:50
Posts: 438
softwarejanitor wrote:Do you
softwarejanitor wrote:

Do you have a link to that keyboard?  I wasn't aware anyone was making a new keyboard for a //e.

 

 

-- Edit --  Must be new.  I googled it and it says "picture coming soon" and it isn't showng on their store yet.

 

 

They tend to kickstart large projects first before selling them out right. You can see some photos and a video there. But as far as I was aware, it was just the power led. Not all the keys. 

 

https://www.kickstarter.com/projects/maceffects/mechanical-keyboard-for-the-apple-iie-computers-clear-and-gray

clockchip's picture
Offline
Last seen: 2 months 5 days ago
Joined: May 23 2018 - 16:33
Posts: 26
https://youtu.be

https://youtu.be/4Ki3oKpLqoo

Here is a short video about it

Offline
Last seen: 2 days 21 hours ago
Joined: Apr 26 2016 - 08:36
Posts: 707
What brightness are you

What brightness are you referring to?

The MacEffects keyboard has only two LEDs - a green one for power on and a red one to indicate that CAPS-LOCK is on.

With the regular IIe's diffuser lens on the case between the ~ key and the open-apple key you will easily see the power LED, but the red caps-lock LED might be partially obscured.

The MacEffects keyboard comes with a replacement diffuser lens that says "enhanced" on it and allows you to see both LEDs.

 

I don't know of any resistor that needs to be soldered on it.

 

clockchip's picture
Offline
Last seen: 2 months 5 days ago
Joined: May 23 2018 - 16:33
Posts: 26
i am talking exactly about

i am talking exactly about these two LED.

The brightness of these LEDs is so low that it is hard to see if they are powered on. (no cover or lens in between).

Some of the Youtube videos are showing bright LEDs and some  have the same problem as I have (the video which I have posted above).

There is a resistor named R6 which should have an inpact on the LED maybe this one is wrong populated.

 

 

Offline
Last seen: 11 hours 30 min ago
Joined: Jun 6 2020 - 10:50
Posts: 438
Did you measure the resistor?

Did you measure the resistor? Or if it's through hole, what are the color bands? If it's SMD, what is printed on it?

 

 

Without knowing the exact specs of the LED used, we can't tell you what the value should be. But generally if it's a 5v circuit, the resistor would most likely be less than 560ohms or so (based on my limited experience with messing around with LEDs). But if it was supposed to be say 330ohms, and the resistor used was 3.3k, then it would be pretty apparent the wrong value was used.

Offline
Last seen: 2 months 2 weeks ago
Joined: Jul 5 2018 - 09:44
Posts: 2587
A couple of places I've seen

A couple of places I've seen online complain that the LEDs on these keyboards are dim.  One place mentioned that these keyboards are supposed to include a new "Enhanced" diffuser plate which is more transparent than the original Apple ones.  But it sounds like even with that, they may be using too big of a resistor to allow the LEDs to be bright enough.

 

clockchip's picture
Offline
Last seen: 2 months 5 days ago
Joined: May 23 2018 - 16:33
Posts: 26
Found the  problem R6 should

Found the  problem R6 should be 470 ohm (got that feedback from MacEffect) but is populated with an 10k resistor.

Offline
Last seen: 2 months 2 weeks ago
Joined: Jul 5 2018 - 09:44
Posts: 2587
clockchip wrote:Found the
clockchip wrote:

Found the  problem R6 should be 470 ohm (got that feedback from MacEffect) but is populated with an 10k resistor.

Wow, that would sure do it!  Even a 1K resistor would make it noticeably brighter...

 

Offline
Last seen: 11 hours 30 min ago
Joined: Jun 6 2020 - 10:50
Posts: 438
That's an odd miss. Like In

That's an odd miss. Like In my example I could see mixing up 470 with 4.7k, 47k, or even 470k. But not sure how you mix up something with completely different values (not including the multiplier). 

Offline
Last seen: 2 days 21 hours ago
Joined: Apr 26 2016 - 08:36
Posts: 707
nick3092 wrote:That's an odd
nick3092 wrote:

That's an odd miss. Like In my example I could see mixing up 470 with 4.7k, 47k, or even 470k. But not sure how you mix up something with completely different values (not including the multiplier). 

Well, a lot of these keyboards were shipped with the ' and ; keys in swapped positions.  

They were all assembled in China in a facility that doesn't normally do this soirt of thing (I figure) so mistakes were made over the course of the production run.

 

Quality control didn't seem to be a "thing"...except for the people at Mac Effects.

jwg1962's picture
Offline
Last seen: 1 day 22 hours ago
Joined: Jan 29 2012 - 07:17
Posts: 363
I haven't even opened mine

I haven't even opened mine yet. Thanks for this info or I would have been banging my head against the wall when mine does this. Ha Ha 

 

Jay 

 

clockchip's picture
Offline
Last seen: 2 months 5 days ago
Joined: May 23 2018 - 16:33
Posts: 26
Hello,back again from my

Hello,

back again from my vacation in Italy, I started to implement the whole thing practically in my basement workshop.

I found out that R6 is responsible for the CapsLock LED and R7 for the Power LED.

As already figured out the R6 resistor was equipped with 10K and now I also discovered that R7 was equipped with 20K.

Both R6 and R7 were supposed to be 470 ohms. I replaced them both with a 470 ohm resistor and everything now works perfectly.

It is worth mentioning that the third resistor on the PCB (I do not know what this is for) has a value of 470 ohms ;-)

 

regards

Clockchip 

Log in or register to post comments