Apple II only sees 1st 32K

3 posts / 0 new
Last post
Offline
Last seen: 1 month 3 weeks ago
Joined: Jun 22 2019 - 09:48
Posts: 2
Apple II only sees 1st 32K

I have a couple of issues with an Apple II+ that I got recently. As I don't have any good documentation on it and I found this forum I thought I'd give it shot here.

 

When running Apple II Confidence program I only see/can test the 1st 32K of memory (the last 16K between 32 and 48K isn't visible). The 1st 32K checks out without any issues through several passes so clearly something with the last 16K. If it was RAM chip(s) that was the issue I would have assumed that I would have seen the full 48K and that the RAM test would have nailed it down to the correct RAM chip(s).

 

Also, if I connect the language card the machine freezes upon power-on with garbled characters on screen.

 

Which chip controls the last bank of 16K?

 

Which row of RAMs is which part (16K, 32K and 48K)?

 

Any other suggestions?

 

TIA!

Offline
Last seen: 1 day 14 hours ago
Joined: May 20 2016 - 06:57
Posts: 48
The row of RAMs that is

The nearest to the slots row of RAMs is the third 16K bank.  If you have removed a DRAM chip from that row in order to connect a language card's cable  make sure you put it back correctly when the card is not plugged in the computer. Any one of eight chips in that row may render the whole 16K bank inoperative.

Offline
Last seen: 1 month 3 weeks ago
Joined: Jun 22 2019 - 09:48
Posts: 2
Thank you for the tip! It

Thank you for the tip! It wasn't any RAM chip that was bad on the mainboard or the language card and no TTL chip either, it was the F8 ROM on the language card that was faulty. I removed the F8 ROM from the mainboard and replaced the faulty one on the language card and all of the sudden everything is working and 48K and 16K language card RAM passes! :-)

Log in or register to post comments