Apple IIgs will no longer recognize 3.5 drives

3 posts / 0 new
Last post
Offline
Last seen: 1 year 2 months ago
Joined: Aug 12 2015 - 20:44
Apple IIgs will no longer recognize 3.5 drives

I have an Apple IIgs that has been working just fine. But today, I find the 3.5" drives are not recognized any more, however the eject button does still function. I have two 3.5" drives and one 5.25" drive. The 5.25" drive is at the end of the chain, and it is still working. I removed the 3.5" drives and tried them with my Macintosh 128k, and it recognizes each of them. The Apple IIgs also passed the diagnostic test. What can I do?

Offline
Last seen: 7 hours 16 min ago
Joined: Jul 31 2014 - 17:48
Re: Apple IIgs will no longer recognize 3.5 drives

Hi,
It could be related to the 3.5 select line, as the IWM seems to be working OK with the 5.25 drives. The 3.5 select line is driven from the VGC chip, Apple must have added this function into it for some reason. You could try removing and reinserting the VGC chip, or else if that fails, they have been available on eBay sometimes. Might be worth a try to fix this.

/Rob

Offline
Last seen: 1 year 2 months ago
Joined: Aug 12 2015 - 20:44
Re: Apple IIgs will no longer recognize 3.5 drives

Ah, thanks for the reply Rob. A little further searching came up with several topics in various forums with the same issue. Unfortunately, the VGC chip in this logic board is soldered, so I can't re-seat it. I checked eBay, and none are currently available. I'll keep my eyes peeled. For now, it looks like i'm in the market for a new logic board and I'll set this one aside until I can source a suitable VGC.

Log in or register to post comments