Apple Lisa Mouse Repair

3 posts / 0 new
Last post
Offline
Last seen: 8 months 3 weeks ago
Joined: Jan 19 2014 - 15:25
Apple Lisa Mouse Repair

Hello,
I have an Apple Lisa 1 mouse that's having some problems. It moves perfectly vertically, but won't move at all horizontally.
I've already cleaned the ball and rollers, and even when I move the roller with my finger, there's no horizontal movement.
I checked all continuity of all circuits on the board. They all work perfectly.
Does anyone know what's going on here?

Tom

spicybeef's picture
Offline
Last seen: 1 year 7 months ago
Joined: Mar 13 2014 - 16:01
Re: Apple Lisa Mouse Repair

When you say you checked the continuity of all circuits on the board what exactly did you verify? Trace continuity? Continuity from PCB to the connector? My guess would be a problem with the encoder wheel and the associated sensors. If you can, try comparing the receiver signal of the non-working encoder assembly to the working one. Moving the encoder wheel will cause the voltage to fluctuate in a pattern that should be reproducible on both axes. Without the mouse in hand, pictures, or a schematic, this is my best guess.

Offline
Last seen: 4 months 4 weeks ago
Joined: Jun 21 2012 - 21:40
Re: Apple Lisa Mouse Repair

You should see 5V PP data on both encoders, you could look on the female connector inside the Lisa with an ocilloscope, or just use the AC Volts on a DVM. You should see data when moved, no voltage when stopped. I suspect a photo-interrupter is bad, or simply stuck and not moving.

Log in or register to post comments