videx vidterm clone bad rom

8 posts / 0 new
Last post
Verault's picture
Online
Last seen: 20 min 37 sec ago
Joined: Dec 21 2017 - 14:19
Posts: 107
videx vidterm clone bad rom
My videx clone has a bad ROM chip, Its the one circled in this photo.  The eprom is a MB8516, and I would like to erase it and reprogram it, but this card has 3 eproms and I dont know which rom I need or where to find it. Hope someone can help me out. Thanks!
macnoyd's picture
Offline
Last seen: 6 hours 15 sec ago
Joined: Oct 15 2012 - 08:59
Posts: 628
As I recall, they were all 2716's

As I recall, they were all 2716 EPROMS.

Verault's picture
Online
Last seen: 20 min 37 sec ago
Joined: Dec 21 2017 - 14:19
Posts: 107
Well Like I said its a clone,

Well Like I said its a clone, but I just checked my videx branded vid term card and the two top horizontal roms are 2716 and the lower vertical one (the one I need to replace) is a 2708 on the videx branded card.

Offline
Last seen: 7 hours 50 min ago
Joined: Jun 18 2010 - 13:54
Posts: 306
Don't put the real Videx 2708

Don't put the real Videx 2708 EPROM into the clone, but if you have a programmer that will read it then copy its contents into both halves of a 2716 and use that in the clone.

Verault's picture
Online
Last seen: 20 min 37 sec ago
Joined: Dec 21 2017 - 14:19
Posts: 107
Jeff could you please explain

Jeff could you please explain why you are asking me to do that?

Offline
Last seen: 7 hours 50 min ago
Joined: Jun 18 2010 - 13:54
Posts: 306
You said that you suspect the

You said that you suspect the Program EPROM on your Videoterm clone is bad. But you also said that you have a real Videx board that has working ROMs. The only differenece seems to be that the Videx board uses a 2708 while the clone has a 2716 EPROM instead. So you just need to program a 2716 with 2 images of the Videx firmware and that should bring it back to life. You can either read your working ROM or try the  Videx Videoterm ROM 2.4.bin  image here:

 

 

 

Offline
Last seen: 3 days 4 hours ago
Joined: Aug 4 2018 - 21:59
Posts: 138
jeffmazur wrote:You said that
jeffmazur wrote:

You said that you suspect the Program EPROM on your Videoterm clone is bad. But you also said that you have a real Videx board that has working ROMs. The only differenece seems to be that the Videx board uses a 2708 while the clone has a 2716 EPROM instead. So you just need to program a 2716 with 2 images of the Videx firmware and that should bring it back to life. You can either read your work

 

The clones use a 2716, the firmware comes in two different flavours.  One with 60Hz vertical retrace timing and another with 50Hz.Which version you use will depend on how your Apple is configured, if your screen starts rolling everytime you switch to the 80 column card then you need the other vesrion.

Verault's picture
Online
Last seen: 20 min 37 sec ago
Joined: Dec 21 2017 - 14:19
Posts: 107
Well I would assume I need

Well I would assume I need the 60 hz NTSC version since I live in the land of NTSC and 60hz

Log in or register to post comments