Apple //e Joystick fire button

7 posts / 0 new
Last post
Offline
Last seen: 16 years 10 months ago
Joined: Dec 20 2003 - 10:38
Posts: 13
Apple //e Joystick fire button

I can't seem to figure out why my Apple IIe Joystick isn't functioning on Donkey Kong, ok i know it's Donkey Kong, what the hey, but I'd like to be able to play some of the old games. I've upgraded it from Apple II status to Apple //e enhanced and still no luck. Any advise, am I missing something. Also, my composite color monitor seems to be off on color.

Thanks,
Darkhawk

resman's picture
Offline
Last seen: 1 month 1 week ago
Joined: Feb 9 2006 - 12:41
Posts: 217
Contact cleaner

I had a non-functional //e joystick fire button as well. Disassemble the joystick and pull out the button mechanism. Be careful as there is a very small spring that goes between the actual button mechanism and the orange button. Douse the mechanism in contact cleaner and work it in by pressing the button. Let it dry a few minutes then give it a whirl. Worked for me, hopefully it will work for you too.

Dave...

Offline
Last seen: 16 years 10 months ago
Joined: Dec 20 2003 - 10:38
Posts: 13
Thanks Dave

Hey Thanks for the tip I'll try it out. Any ideas on the color monitor? I'm trying to play Rampage and i'm not haveing any luck with the color at all. It looks pretty crappy on the Monochrome as well. Maybe it's the game. Hawk

Offline
Last seen: 1 year 10 months ago
Joined: Sep 3 2005 - 04:23
Posts: 104
>Also, my composite color mon

>Also, my composite color monitor seems to be off on color.

what does that mean?

Offline
Last seen: 16 years 10 months ago
Joined: Dec 20 2003 - 10:38
Posts: 13
Lines in screen

Ok so i'm confused now. I've changed out my motherboard to a newer one dated 1984 and it has all the enhanced chips, shows //e on the screen but games like Qix and Rampage will not show correctly on the screen. The monitor seems to be fine on games with lower resolutions. Do I need a different cable? Am I missing something?

Offline
Last seen: 16 years 10 months ago
Joined: Dec 20 2003 - 10:38
Posts: 13
Ok got it fixed!

So I figured out that you need a board with the enhanced chips an 80 column card with 64K memory and yes you need the jumper installed! Eureka! It worked! The previous 1982 board w/o enhanced chips and the 80 column card didn't work. It seems only the newer boards supports double hi-res. So now i'm playing good ol Qix and Rampage with no worries. Oh yea the contact cleaner worked on the joystick! Thanks all.

resman's picture
Offline
Last seen: 1 month 1 week ago
Joined: Feb 9 2006 - 12:41
Posts: 217
Old //e

Wow, you had a really old //e. Only the rev A didn't support double hires. Glad to hear you got it working. I'm having a lot of fun going through all the archives finding treasures I never knew existed. Low end hardware forced game designers to focus on gameplay, not just flashy graphics. I find playing them on real hardware is much better than an emulator.

Dave...

Log in or register to post comments