Apple II Rev 0 E8 Rom Issue

4 posts / 0 new
Last post
Offline
Last seen: 1 month 3 weeks ago
Joined: Jun 8 2020 - 01:48
Posts: 3
Apple II Rev 0 E8 Rom Issue

Hello Everyone,

I am the proud new owner of a Rev 0 Apple ][ that has quite the strange issue.  It came with an early set of Applesoft ROM's and the board passes the Apple ][ diagnostics 100%.  No problems with games, program's.  Everything works great. I have several sets of integer basic roms along with the multiple original ROM cards.  Being that this machine shipped with the non-autostart monitor and integer roms, I wanted to swap the applesoft roms with the integer roms on one of my cards and have the unit in a more original state.  So, I swapped the integer roms in.  System boots up, I can run integer basic programs like color demo and other programs just fine.  Run Apple ][ Diagnostics and it fails on ROM E8.  I pulled the ROM card, now with the Applesoft roms out.  Re-run diagnostics. E8 failure.  Ok, I must have a bad rom, so I swapped my other board E8 rom and tested. E8 rom failure.  Ok, two bad E8 roms.  Really?  I put the roms back in the ROM card and swapped into an Apple ][+.  Diagnostics succeed.  Same for the other board.  Hmm.  Ok, I'll build a 2716 ROM set and strap the ROM board to accept 2716's.  Done.  Rev 0 E8 failure, ][+ 2716's pass all diagnostics. Hmmm.....

 

Double check the original Applesoft ROM's.  Diagnostics pass.  Hmm. Then, I put every rom I have through the motherboard and ROM card, bsaving the rom to a file on a CFFA blank floppy.  Pull floppy back to my PC and compare all files with known good binaries from asimov.  All files verify perfectly, applesoft, integer and 2716 integer. Hmmm... I'm starting to run out of ideas... Search Applefritter and found the following thread.

https://www.applefritter.com/content/fixed-apple-ii-plus-bad-memoryrom-saga-continues

 

Read to end of thread, and basically this person just finds a ROM that works.

 

This all smells of a tight timing condition on the E8 socket.  I somewhat want to disassemble the ROM testing routine in the Apple ][ diagnostics to understand how the ROM is failing.  Again, the interesting part is that the system appears fully functional; it just fails diagnostics on any Integer E8 rom or prom that I have.

 

If any of you Apple ][ guru's out there have any insight into a solution, or even a technical description of the problem, I would be all ears..

 

 

 

 

 

 

Offline
Last seen: 17 hours 45 min ago
Joined: Nov 7 2019 - 13:49
Posts: 119
Which diagnostics disk

Which diagnostics disk exactly are you using?

The original Apple II diagnostics disk contains a binary copy of each ROM image and compares the installed ROMs byte by byte to the copy on the disk. So, if you change (update) any installed ROM, then the test will fail.

Offline
Last seen: 1 month 3 weeks ago
Joined: Jun 8 2020 - 01:48
Posts: 3
The one thing I took for

The one thing I took for granted was the diagnostics disk.  My disk is different, and fails.  The disk you linked works fine....problem solved.

Anyhow, great catch!  I haven't worked with or had an apple ][ before, so I wasn't aware there would be a difference with a plus.

Offline
Last seen: 1 week 2 days ago
Joined: Mar 16 2018 - 01:55
Posts: 26
The only thing that differs

The only thing that differs between the multiple ROM sockets is which output of the 74LS138 drives them. You might try replacing that.

Log in or register to post comments