Apple IIe PAL 820-0073-B does not boot

7 posts / 0 new
Last post
Offline
Last seen: 5 months 1 week ago
Joined: Oct 1 2015 - 18:53
Apple IIe PAL 820-0073-B does not boot

Hi All,
somebody can help me?
No BEEP, no DRIVE running; only garbage on screen (see pic)
Cleaned pins of ROM, CPU but nothing.
Any idea?

Step2
Replaced all 3764 with 4264...some time at switch on I hear the beep but always garbage. Reset combination works but the drive runs for few seconds without success.

Step3
Tried to replace the 6502 with 65c02 removed from working iic. Nothing

Step4
Tried to replace the rom with iic rom. Only vertical strips on monitor.

My doubt is a sort of "white oxidation" found on the IC of existing rom (see pic).
I've found this on ebay,

https://rover.ebay.com/rover/0/0/0?mpre=https%3A%2F%2Fwww.ebay.com%2Fulk%2Fitm%2F201822216278

someone can suggest me if purchasing?
Could be the problem?

AttachmentSize
Image icon IMG_20171203_163654.jpg1.62 MB
Image icon IMG_20171205_004240.jpg1.13 MB
Offline
Last seen: 5 months 1 week ago
Joined: Oct 1 2015 - 18:53
Re: Apple IIe PAL 820-0073-B does not boot

Hi everbody,
nobody reply...sigh sigh
In the meantime thanks to other people on FB I've tried differnt ways.
Replaced EF+VID+CD Rom and CPU. Now the Aplle is enhanced but the problem is the same. No one little changing...so strange.
I've checked the power supply output voltage. Correct as per apple spec.
The only doubt now is the PAL-HAL which is little bit hot when the machine is powered.
Anybody can help me to understand how to check this to see if faild?
Thx

amauget's picture
Offline
Last seen: 21 hours 13 min ago
Joined: Jan 3 2011 - 11:34
Re: Apple IIe PAL 820-0073-B does not boot

Hi Ciprix73,

Unlike the Apple II, the //e uses a lot of proprietary circuits such as MMU, IOU, HAL. They are hard to find these days.
Your problem may be related to one of this chip or to the RAM chips, or to some expansion card...
So remove all the cards in the Apple and try to boot.
You can also try to launch the internal diag : unplug the keyboard and switch the power on. If an error is detected, it will be printed on the screen.

Offline
Last seen: 5 months 1 week ago
Joined: Oct 1 2015 - 18:53
Re: Apple IIe PAL 820-0073-B does not boot

Hi Amauget,
many thanks for your reply.
No cards are inserted. Even if the keyboard is removed the screen remain locked as the pictures.
I tried also to relace all the 8 RAM bank without success.
Now, following also some suggestions, it seems could be or the LS125 or the MMU IC...I hope the first.
Do you have any experience with these components?

amauget's picture
Offline
Last seen: 21 hours 13 min ago
Joined: Jan 3 2011 - 11:34
Re: Apple IIe PAL 820-0073-B does not boot

Ciprix73,

Not much... But if you want to tinker, you can always read the excellent Understanding the Apple //e from Jim Sather.

Offline
Last seen: 5 months 1 week ago
Joined: Oct 1 2015 - 18:53
Re: Apple IIe PAL 820-0073-B does not boot

Hi, I have replaced all the IC less the property ones like IOU, MMU, KEY ROM and HAL.
I haven't solved the problem.
Using an oscilloscope and the interesting IIe tech ref.manual I'm noticing some bad signal on IOU and MMU chips. Now, because I have a working IIc board, can I replace the IOU and MMU simultaneously?

Online
Last seen: 19 min 27 sec ago
Joined: Aug 18 2017 - 16:53
Re: Apple IIe PAL 820-0073-B does not boot

Ciprix73 wrote:
Now, because I have a working IIc board, can I replace the IOU and MMU simultaneously?

I don't think so. Look at AppleLogic.org.

But these information cannot be completely correct because my own IIe Rev.A from 1983 runs the IOU 344-0022-A after the failure of the original one.

Regards, Ralf

Log in or register to post comments