Did the Unitron U2000 have colour?

11 posts / 0 new
Last post
Offline
Last seen: 1 month 4 weeks ago
Joined: Nov 24 2013 - 13:23
Posts: 212
Did the Unitron U2000 have colour?

Hey guys.

I just finished repairing the keyboard on my U2000 after 4 years of being inop.  Was quite a process.  So I fired up a game to test things out fully and was surprised to see it's completely grayscale, even on a color monitor.

I'm wondering if this is a bug or a feature.  I'm curious if Unitron incorporated the color burst circuitry of the original Apple II.  It seems to be a straight up copy but maybe they cut a corner to save money or to reflect the fact that their target markets were probably mostly using monochrome?

Anyone out there with a unitron that can answer that? 

Thanks!

Offline
Last seen: 1 day 11 hours ago
Joined: Jul 5 2018 - 09:44
Posts: 320
Is that an NTSC or PAL model?

Is that an NTSC or PAL model?

 

Offline
Last seen: 8 hours 49 min ago
Joined: Dec 19 2008 - 21:01
Posts: 282
I don't have one, but that

I don't have one, but that would be really strange not to have the color circuitry.  Maybe if they marketed it solely as a business computer they could skip it... 

Offline
Last seen: 1 day 11 hours ago
Joined: Jul 5 2018 - 09:44
Posts: 320
I'm in the US so I don't know

I'm in the US so I don't know from personal experience, but I've read that some of the European clones didn't include color standard because PAL color was kind of a messy hack from an Apple II.

 

Offline
Last seen: 1 month 4 weeks ago
Joined: Nov 24 2013 - 13:23
Posts: 212
Officially this machine has a

Officially this machine has a 'Linden' badge and from what I can gather was sold up here in Canada.  It is all Unitron hardware inside though.  I think Unitron had some kind of deal, maybe to avoid impoundment by customs, to sell components to 'OEMs' who'd assemble them and badge them as their own.  When you fire up, you even have 'LINDEN' rather than Unitron (or what would have been Apple II) onscreen.

From what I can see having taken it apart again, all the circuitry for color is there -- there's a color trim knob and the colorburst ICs where you expect them.  So either we've got a problem somewhere, or for some unknown reason they disabled color on this unit.

Offline
Last seen: 1 day 11 hours ago
Joined: Jul 5 2018 - 09:44
Posts: 320
If it was sold in Canada, it

If it was sold in Canada, it is almost surely a 110V and NTSC model, so the PAL questions are probably irrelevant.

 

The kind of deal you talk about to sell through independent local companies was pretty common back then, exactly for the reasons you mentioned -- to avoid issues with customs and copyright infringement.  There were dozens of such companies here in the US that sold Apple II clones and clone parts imported mainly from Taiwan and Hong Kong under various different brand names.

 

If the color trim has no effect then it does sound like there is some kind of problem.  Have you looked at the repair manuals that are available for download on Asimov, etc?

 

 

Offline
Last seen: 1 month 4 weeks ago
Joined: Nov 24 2013 - 13:23
Posts: 212
I didn't see anything

I didn't see anything specific to the U2000 on Asimov.. just the U2200.  There is a fellow with a slightly more detailed site and lots of high res pics here:   http://www.applelogic.org/UnitronAndI.html    I was really grateful that he dumped the EPROMs because the one on my keyboard was totally fried.

I'll try swapping chips with one of my II+ machines and see what we can get out of this.

Thank you for the suggestions.  They're kind of cool machines.. love the blue PCB.

Offline
Last seen: 8 hours 49 min ago
Joined: Dec 19 2008 - 21:01
Posts: 282
I had a II+ that had no color

I had a II+ that had no color and it turned out to be the 14.xxx crystal had gone out of spec... I changed it and color came back.

 

Offline
Last seen: 4 weeks 8 hours ago
Joined: May 20 2016 - 06:57
Posts: 46
falter, could you post

falter, could you post pictures of the motherbard, especially of the jumpers on the right side which  switch between 50 and 60Hz  (PAL & NTSC) framerate ?

Offline
Last seen: 1 month 4 weeks ago
Joined: Nov 24 2013 - 13:23
Posts: 212
The machine is assembled

The machine is assembled right now and I haven't had time to pull it apart.  I don't know if this photo will show the jumpers you're looking for but here's one from the last time I had it apart to start:  https://drive.google.com/file/d/1l_WOqV6bNRyotp57HWp9GtfyzEvpI1fG/view?usp=sharing

If that doesn't help let me know and I'll unscrew the thing sometime this weekend and do more direct photo.

EDIT: Here's another from the right side.  Bit blurry but... https://drive.google.com/file/d/1C36Unv6S47uckznIRJqirLp8-2vnfY6O/view?usp=sharing

Offline
Last seen: 8 hours 49 min ago
Joined: Dec 19 2008 - 21:01
Posts: 282
That is pretty much a mostly

That is pretty much a mostly straight copy of the II+ board, just with a pretty color. It should have color capability...

 

Log in or register to post comments