Flash Compatible NVidia Cards

29 posts / 0 new
Last post
protocol6v's picture
Offline
Last seen: 8 years 11 months ago
Joined: Apr 21 2006 - 20:58
Posts: 339
Flash Compatible NVidia Cards

Could anyone direct me to somewhere that has a list of compatible NVidia video cards, that I could flash over to mac? I was really looking to flash either a GeForce 7600 GS 512MB, or a GeForce FX 5200 256MB.

Thanks!

It would help if that page had the flash files or where to get them too. Help is much obliged. Thanks.

dankephoto's picture
Offline
Last seen: 1 year 9 months ago
Joined: Dec 20 2003 - 10:38
Posts: 1900
strangedogs forums . . .

is the place to go for that info.

strangedogs

Just curious, what sort of card do you want (AGP or PCI-e or?) and for which Mac? What do you intend to use it for?

For my QS I flashed a PC GF3 64MB, it's nearly as fast as my OEM Apple GF4Ti 128MB card in the same machine, but was loads cheaper.

dan k

protocol6v's picture
Offline
Last seen: 8 years 11 months ago
Joined: Apr 21 2006 - 20:58
Posts: 339
I was just there, they don't

I was just there, they don't seem to have one for the 7600. Does that mean it can't be flashed, or have they just not updated that page in a while?

dankephoto's picture
Offline
Last seen: 1 year 9 months ago
Joined: Dec 20 2003 - 10:38
Posts: 1900
the problem . . .

is that there is no Mac version of that card, so it's extremely unlikely there will be a flasher without a similar OEM Mac card to copy from.

Since Apple has moved on from PPC and AGP, I'm afraid yer choices are going to be very limited. There are flashes for some of those older cards, like the 6800, 5200, etc. for which there are OEM Mac cards. Read through the strangedogs fora for details. If anything new pops up, you can be sure it will get lots of discussion there.

which-cards-FAQ

*edit*
I'd love to see the 7600gs in my Mac, I just bought one for my PC and it's not too shabby. Still, it wasn't a quantum leap forward from my PC's old GF4Ti4600 128MB (same basic card as in my QS!) I think these old AGP Macs are pretty much maxed out on even something as old as the GF4. Newer cards are just going to be waaay overkill.
/*edit*

dan k

Jon
Jon's picture
Offline
Last seen: 8 years 3 weeks ago
Joined: Dec 20 2003 - 10:38
Posts: 2804
My P3 machine shows that limi

My P3 machine shows that limit too. It's stuck on 2x AGP with a 440BX chipset. It came with a GF2 MX200 32MB DDR card. I swapped in a GF4 MX440 8x AGP 64MB DDR and while faster it didn't show much of a leap. When ever I get a 4x or 8x AGP machine the bus difference should show much better, and then the generation step of the card and VRAM on top of that. Being stuck on a slower AGP bus (1x or 2x) really limits what a card can get done, no matter what it's actual capabilities are.

protocol6v's picture
Offline
Last seen: 8 years 11 months ago
Joined: Apr 21 2006 - 20:58
Posts: 339
Ok, I'm stumped. I'm sitting

Ok, I'm stumped. I'm sitting here with a GeForce 5200 256MB AGP card, and i would love it if someone could direct me to a how to flash to mac guide or something. I'm going out of my mind.

Thanks.

Offline
Last seen: 3 years 11 months ago
Joined: Sep 23 2005 - 13:29
Posts: 316
hit the forums

check out the strangedogs forums, and cubeowners forums...

its real easy to do,i did a 128mb FX5200 last night first try.

for the basic process what youre going to need is the following:

a PC with a PCI bus, an AGP slot, and a bootable floppy drive, then go to strangedogs forums and download the rom for your 5200 (either 64bit memory or 128bit memory), next hit the cubeowners forum post (linked from strangedogs "HOW TO FLASH A 5200" section of their FAQ) and download a Windows ME boot disk image, (it'll be and EXE) run the boot disk image EXE program (under windows) It'll make a windows ME boot disk....

delete some unneeded stuff from the boot disk to free up some room... copy the NVFlash tools to the bot disk, and the ROM you downloaded.

Make sure all of the filenames are 8 characters or less, so that you have no trouble in DOS...

then, in the PC that you will be doing the ACTUAL flahsing in... install a NON Nvidia chipset video card on the PCI bus, set the bios to use the PCI card as default and power off the machine.

Install the AGP card to be flashed in the machine, insert the boot floppy and turn on the machine...

after the boot floppy loads (select option 2, if you follow the post linked from strangedogs) CD to the NVFlash directory of the floppy and make a backup of the cards firmware like so:

nvflash -b old.rom

this wil make a rom image named "old.rom" that is a backup of the card if you mess something up. if making a backup gives error messages, delete the newly created file and keep freeing up space on the floppy until the backup file is created properly.

then, flash the new firmware:

nvflash -f [your_Rom_File_Name_Here].rom -5 -6

power off the PC, remove the newly flashed AGP card and put it in your Mac, press the power key.

if done properly, all should be good.... especially with a 5200... its REAL easy to flash for mac.

(truth be told, it took longer to type this post than it took me to set up a machine and flash my card last night.)

Can this be done on a Mac, without any PC involvement at all? well... the answer is "sort of" it is MUCH MUCH more difficult, and you have to run with no video display for a while as well.... too scary for me. Easy to flash from a boot floppy though. Smile

/Bill

protocol6v's picture
Offline
Last seen: 8 years 11 months ago
Joined: Apr 21 2006 - 20:58
Posts: 339
Hey, thanks. I found that sam

Hey, thanks. I found that same article just after i posted. I'm going to try it tomorrow or saturday. I wouldnt mind doing this with no video, thats what Timbuktu is for, but its probably easier just to use a PC(the one thing that IS easier!).

madmax_2069's picture
Offline
Last seen: 8 years 6 months ago
Joined: Sep 24 2005 - 07:28
Posts: 664
well couldent you just use a

well couldent you just use a ATI pci video card to output video to in the Mac so you dont have to work blind folded and since its a ATI card and the AGP card is nvidia shouldent it be the same as having 2 video cards with diffrent chipsets in a PC with it useing the pci card as the main card that is if you set the ATi as the main card for OS X to use. That is if you have a second non nvidia pci video card for Mac.

Offline
Last seen: 3 years 11 months ago
Joined: Sep 23 2005 - 13:29
Posts: 316
well..

yeah, except that the flash tools are really easy to use on a PC... and im not sure if you can set boot priority on a mac video card... its definetly NOT impossible to do on a mac, just... if you've got the hardware laying around (and i would assume that most of us do) then it is easier to do it on a PC.

protocol6v's picture
Offline
Last seen: 8 years 11 months ago
Joined: Apr 21 2006 - 20:58
Posts: 339
Ok, I'm stuck again. The nvfl

Ok, I'm stuck again. The nvflash utility is complaining that the .rom file doesnt match the board ID, how can i override this? Or does anybody have a rom that will match a board ID of (supposedly) 0000?

protocol6v's picture
Offline
Last seen: 8 years 11 months ago
Joined: Apr 21 2006 - 20:58
Posts: 339
NVM. I'm just going to return

NVM. I'm just going to return the card while it still works in PCs and buy an ATI. Is it true that you can just flash an ATI right on a Mac?

Offline
Last seen: 3 years 11 months ago
Joined: Sep 23 2005 - 13:29
Posts: 316
if you...

if you still want to give it a go... can you tell me exactley which card you have, and i will make a floppy image that you can try. what the heck, it wouldn't hurt to give it one more shot right. plus the 5200's are Usually very flash friendly.

protocol6v's picture
Offline
Last seen: 8 years 11 months ago
Joined: Apr 21 2006 - 20:58
Posts: 339
Its the NVidia GeForce 5200 2

Its the NVidia GeForce 5200 256MB AGP 8x (also 2x and 4x compatible). It can be found here...

http://www.microcenter.com/byos/byos_single_product_results.phtml?product_id=246423

That is the exact one.

Thanks a bunch, you can send the image to . I appreciate the help.

Offline
Last seen: 3 years 11 months ago
Joined: Sep 23 2005 - 13:29
Posts: 316
SORRY FOR THE DELAY

sorry it took me so long to reply, my girlfriend and I ended up going out for a while... anyway, since you and I both have GMAIL accounts, and Gmail will not let you send .exe as an attachment, even as a zip file... I just threw up a quick and dirty html page on my site with a .ZIP download containing everything you should need.

This page also gives you a quick and dirty step by step using the tools I provided.

For anyone that is interested in using this just a note... the ROM that is in my zip file is only for NVidia Geforce FX 5200 (and 5500) cards with 128bit memory arcitechture. (although, im pretty sure it will work on 64 bit cards as well)

anyway, give it a go and let us know how it worked out for you.

Heres the link

http://www.onefallinghope.com/nvidia.html

/Bill

NOTE: I would like to again add that i did NOT create the ROM file here, and the real work was done by other people. i just compiled it into this one little page.

protocol6v's picture
Offline
Last seen: 8 years 11 months ago
Joined: Apr 21 2006 - 20:58
Posts: 339
Thanks so much. I'll shoot ov

Thanks so much. I'll shoot over to Micro Center tomorrow and pick the card back up. Hopefully this rom will work.

Thanks again!

Offline
Last seen: 3 years 11 months ago
Joined: Sep 23 2005 - 13:29
Posts: 316
just a note..

if it doesnt, and you still need to return the card....

how to flash to orig. rom back:

set up your system the same way, using the disc that you backed your orig rom up on...

select option 4,
"cd nvflash"
"nvflash -e"
"nvflash -f pcfx.rom -5 -6"

test that the card works in windows, box it up and get your money back. Smile

protocol6v's picture
Offline
Last seen: 8 years 11 months ago
Joined: Apr 21 2006 - 20:58
Posts: 339
I think it's going to work. D

I think it's going to work. Do I still need to do that pin mod to get it to work in a MDD G4 after the flash? I know that before the flash the G4 won't even boot up.

Offline
Last seen: 3 years 11 months ago
Joined: Sep 23 2005 - 13:29
Posts: 316
hmmm....

well, i really dont know... i havent had to do a pin mod to either 5200 card i've done (only done 2 5200's) - but they were both used in Sawtooths.

i do know for a fact that the sawtooth machines i installed 5200's in showed absolutley NO signs of life (other than a power LED) until i flashed the cards, but after the flash they booted right up, grey "preboot" screen and all.

protocol6v's picture
Offline
Last seen: 8 years 11 months ago
Joined: Apr 21 2006 - 20:58
Posts: 339
Yes! That was exactly what ha

Yes! That was exactly what happened with the MDD. I'll shoot over to Micro Center tomorrow morning. I'm not sure when i'll be able to try the flash though, I'm not around any PCs right now. Thanks again!

protocol6v's picture
Offline
Last seen: 8 years 11 months ago
Joined: Apr 21 2006 - 20:58
Posts: 339
Well, i picked the card up an

Well, i picked the card up and this one is blue instead of green. wonder if theres a difference between the chipset or something? I'll post back with my results from the flash that evilrobot posted.

Offline
Last seen: 3 years 11 months ago
Joined: Sep 23 2005 - 13:29
Posts: 316
UPDATED

go back to the link i posted, i added another download (a rom for 256MB 5200 cards) i havent used that particular rom before, as the 5200's i did were both 128MB cards... either way, both ROMS i gave should work, except one of them might only show up as 128MB RAM on your 256MB card. when you download the ROM, reanme it from fx256r2.rom.txt to fx256r2.rom (im actually making a new zip with both roms in it right now.)

anyway, the page has been updated.

/Bill

protocol6v's picture
Offline
Last seen: 8 years 11 months ago
Joined: Apr 21 2006 - 20:58
Posts: 339
Well, i still get the same pr

Well, i still get the same problem with the new flash file evilrobot provided me with. I had to use the newer version of nvflash, otherwise it complains that it can't find a supported eeprom. With the newer version, i can't find the command to erase the eeprom either. Any suggestions? Does anyone know how to tell the nvflash utility to override the board id? i know theres a command in the earlier versions to do that but i have to use the later versions.

Offline
Last seen: 3 years 11 months ago
Joined: Sep 23 2005 - 13:29
Posts: 316
hmmm.... this should cover all versions of the utility

eForce 4 & GeForce FX Flash Procedures.

- Flashing with nvFlash (nVidia) - Use nvFlash v4.XX
Standard Procedure for 4.XX: (flashing with 4.XX is recommended on the GF4 & FX series NVIDIA chipsets)

1. a:nvflash -b backup.rom [Enter]

Standard back-up (saves BIOS to Floppy)

2. a:nvflash -p -u -f file.rom [Enter]

Standard Flash (same card, new firmware)

2. a:nvflash -p -u -r -j file.rom [Enter]

(Different model card, removes eeprom protection, using different firmware)

GeForce 6 & 7 Flash Procedures.

- Flashing with nvFlash (nVidia) - Use nvFlash 5.13
Standard Procedure for 5.13: (flashing with 5.13 is recommended for the use with the 6x00 series NVIDIA cards, using the -4 switch forces flash and overrides vender mismatch)

1. a:nvflash -5 file.rom [Enter]

Standard Flash (same card, same firmware)

2. a:nvflash -5 -6 file.rom [Enter]

Standard Flash (same card, same firmware)

3. a:nvlfash -4 -5 -6 file.rom [Enter]

Force Flash (different model card, different firmware) this is probably what you want

4. a:nvlfash -4 -5 -6 -a -y file.rom [Enter]

Automatic Force/Blind Flash (In case you screw up and cant see the screen - best to use this string for a autoexec.bat)

It is highly recommended to use nvFlash over anything else when flashing NVIDIA cards. Flashing from a Bootable CD is not recommended. If you don't have a floppy, buy one, they are in-expensive while saving loads of hassles on some system configurations.

*Important* If you are using softmods and other tweaking applications, uninstall them prior to flashing. This goes for Riva Tuner and others. Why? Because most people flash, leaving those programs resident, so those utilities, try to force the video card to those saved settings in software and that causes problems for a card with a fresh flash or a new device ID.

*Remember* To always change out the drivers after a flash, most people forget this and then wonder why the drivers are giving them problems or why they get strange effects in there games. Always re-install the drivers and turn off any anti-virus before doing so. Rename the file to something thats easy to remember and point the string path too.

protocol6v's picture
Offline
Last seen: 8 years 11 months ago
Joined: Apr 21 2006 - 20:58
Posts: 339
Thanks, I'll definitly try th

Thanks, I'll definitly try that tomorrow when I get back to my PCs. Why doesn't it show the -4 command in the read me or anything?

Offline
Last seen: 3 years 11 months ago
Joined: Sep 23 2005 - 13:29
Posts: 316
also...

this forums thread has a download of all nvflash versions, it seems a guy there was having a problem with one of his cards eeproms as well.

http://www.laptopvideo2go.com/forum/lofiversion/index.php/t766.html

protocol6v's picture
Offline
Last seen: 8 years 11 months ago
Joined: Apr 21 2006 - 20:58
Posts: 339
Thanks to anyone who helped!!

Thanks to anyone who helped!!! I got it working and it works MUCh better than my Radeon 9000. Thanks especially to evilrobot!

Offline
Last seen: 3 years 11 months ago
Joined: Sep 23 2005 - 13:29
Posts: 316
Awesome!!!

Congrations!! I'm glad you got it working!! For my own personal reference, could you tell me which specific card it was, what version of NVFlash worked for you, and which ROM you used... Im trying to keep tack of this kind of stuff. Also, was a pin mod required?

Again, congrats, welcome to Core Image support. Smile

/Bill

protocol6v's picture
Offline
Last seen: 8 years 11 months ago
Joined: Apr 21 2006 - 20:58
Posts: 339
It was the exact card that i

It was the exact card that i posted a link for. I used nvflash 5.36. And i used the 256mb rom you posted on your site. I had to tape off pins 3 and 11. It wouldn't boot unless i did that.

Log in or register to post comments