Apple IIgs 3.5 Floppy problem

7 posts / 0 new
Last post
Offline
Last seen: 2 months 2 weeks ago
Joined: Jun 6 2018 - 17:32
Posts: 15
Apple IIgs 3.5 Floppy problem

Hi! Recently got a IIGS Woz Edition and cleaning it nicely. My 3.5 drive from the IIGS wasn't working so I watched some tutorials and opened it up: not too dirty but I cleaned it anyway. I discovered I had a broken cog wheel and have a replacement on the way - I re-did the moving parts lubrication with new silicone grease and cleaned the read/write head with alcohol on a cotton swab. Still won't read disks. So far my 5.25 drive works but I can't load GS stuff until I sort the 3.5 drive.

Also, is the drive motor for the auto-eject function or to move the read/write head? If the latter, then that explains it and I must wait for the new wheel part. Otherwise I'd greatly appreciate any contact info on repair services/Super Drive upgrades or advice if it is a simple fix I missed. Many thanks!!

speedyG's picture
Offline
Last seen: 2 hours 7 min ago
Joined: Nov 16 2011 - 07:45
Posts: 2489
There are 2 motors inside:

There are 2 motors inside:
1 spinning disk
1 moving sled while ejection of the disk.

Offline
Last seen: 2 months 2 weeks ago
Joined: Jun 6 2018 - 17:32
Posts: 15
Hmm- the bottom doesn't like

Hmm- the bottom doesn't like spinning for too long. I may be in for finding videos on working on that.

Dog Cow's picture
Offline
Last seen: 3 days 7 hours ago
Joined: Dec 11 2008 - 16:26
Posts: 538
speedyG wrote:There are 2

speedyG wrote:
There are 2 motors inside:
1 spinning disk
1 moving sled while ejection of the disk.

And a third motor to move the read/write head.

Offline
Last seen: 2 months 2 weeks ago
Joined: Jun 6 2018 - 17:32
Posts: 15
Ok so three motors- I see

Ok so three motors- I see when I followed a tutorial the alchohol left a white film on the bottom of the pcb. When I reclean it the bottom wheel spins and the floppy disk can rotate. I must find a way to KEEP the white film off. Maybe some Deoxit product?

I have the eject mechanism lubed well so is it the assembly with the plastic cogs (replacement small on the way) that controls this and the little SONY marked one that does the read/write head or do I have that backwards?

Dog Cow's picture
Offline
Last seen: 3 days 7 hours ago
Joined: Dec 11 2008 - 16:26
Posts: 538
I wrote a blog article on

I wrote a blog article on fixing the 800K disk drive which has some good pictures.

Close up of Sony 800K mechanism -- The silver cylinder to the right of label 1 moves the drive read/write head back and forth. The black motor beneath labels 2 and 4 is the disk eject, as I'm sure you're already aware.

macnoyd's picture
Offline
Last seen: 3 hours 22 min ago
Joined: Oct 15 2012 - 08:59
Posts: 367
The white film is likely a

The white film is likely a combination of the lubricant that you have cleaned off, mixed with the old resin film on the board.
One way to clean this off is with Acetone and a small sash brush, but you will have to re-lube the stepper motor worm shaft with a very thin coat of white lithium afterwards. Same with the mechanism. (just a suggestion)

Log in or register to post comments