Recently aquired IIc Plus

10 posts / 0 new
Last post
subliminal67's picture
Offline
Last seen: 12 years 9 months ago
Joined: Jun 13 2011 - 02:59
Posts: 25
Recently aquired IIc Plus

Hello everyone,

Today I picked up a truckload, no, a TRUCKLOAD of Apple II stuff. In the midst, was a rare gem indeed, a IIc Plus. After arriving home, I shined it up a little, plugged it into the TV (have yet to set up a workbench with a monitor), turned it on, no beep, just a bunch of horizontal white lines. I removed the cover to find a fully loaded AE ram expansion card as well. I see no obvious signs of anything bad, can anyone help? This is the jewel of my 6 hour road trip today.

eeun's picture
Offline
Last seen: 1 year 2 weeks ago
Joined: Dec 19 2003 - 17:34
Posts: 1895
Re: Recently aquired IIc Plus

Congratulations! Big hauls are always fun, and finding a prize inside is even better.

First thing, get yourself a multi-meter and check all power supplies before you use them. I'm pretty sure I fried the ram on a couple 8-bits by using PSUs that were aged and had wandered out of spec. Test them under load, using something like fans, old hard drives or resistors.

You've already had it open, so I'd next try carefully reseating all socketed chips.

gsmcten's picture
Offline
Last seen: 5 years 9 months ago
Joined: Oct 4 2005 - 18:52
Posts: 2629
Re: Recently aquired IIc Plus

Reminds me of opening a CrackerJack box and finding the Official Secret Decoder Ring. lol Smile

subliminal67's picture
Offline
Last seen: 12 years 9 months ago
Joined: Jun 13 2011 - 02:59
Posts: 25
Re: Recently aquired IIc Plus

Thanks guys! Yeah it is like Christmas around here. Wifes not home from work yet though. Wink

There were 4 IIgs's, 1 IIc Plus, and a Platinum IIe, 6 monitors, more disk drives than I can count, including a Rana Systems, loads of boxed software, couple of external hard drives. If I can figure out how to upload pics, I'll put some up.

subliminal67's picture
Offline
Last seen: 12 years 9 months ago
Joined: Jun 13 2011 - 02:59
Posts: 25
Re: Recently aquired IIc Plus

Ok, testing of IIgs are complete, 4 good, ROM 01, 1 bad PS.

Cards:

AE Datalink 2400
Apple IIgs Ram Expansion
Apple SCSI Sandwich II
PC Transporter
GS Ram (2)
Sirius Ram IIgs (Full of SIMMS)
AE Parallel Pro
Focus Drive with 172 meg hard drive attached.

I am pleased Smile

smileyranger's picture
Offline
Last seen: 3 years 9 months ago
Joined: Mar 21 2011 - 20:50
Posts: 167
Re: Recently aquired IIc Plus

Thanks guys! Yeah it is like Christmas around here. Wifes not home from work yet though. Wink

There were 4 IIgs's, 1 IIc Plus, and a Platinum IIe, 6 monitors, more disk drives than I can count, including a Rana Systems, loads of boxed software, couple of external hard drives. If I can figure out how to upload pics, I'll put some up.

Do you think you'd be willing to sell a platinum //e?

subliminal67's picture
Offline
Last seen: 12 years 9 months ago
Joined: Jun 13 2011 - 02:59
Posts: 25
Re: Recently aquired IIc Plus

I might smiley, give me a few days to get things squared away, send me a PM with what you'd like to pay, and I'll see what I can do :bigsmile:

subliminal67's picture
Offline
Last seen: 12 years 9 months ago
Joined: Jun 13 2011 - 02:59
Posts: 25
Re: Recently aquired IIc Plus

Anyway, anyone run into the above problem with a IIc Plus? I don't believe its the power supply, and I'll try reseating the socketed chips after bit. Does anyone know if there was a self test for this model on start up, and how to initiate it?

magnusfalkirk's picture
Offline
Last seen: 15 hours 35 min ago
Joined: Feb 18 2007 - 11:46
Posts: 325
Re: Recently aquired IIc Plus

You could try the same self-test that works on the //e. Press the Open-Apple, Closed-Apple and Reset keys all at the same time, after you turn it on, and that should start the self-test diagnostics. If it prints Kernel OK on the screen then you know it's passed it's own self-test.

Dean

subliminal67's picture
Offline
Last seen: 12 years 9 months ago
Joined: Jun 13 2011 - 02:59
Posts: 25
Re: Recently aquired IIc Plus

I tried the self test, didn't work. I swapped out the 3.5 drive with another IIgs one that I had lying about, that fixed the drive problem. It boots occasionally, sometimes reading the disk, sometimes not. I reseated all of the socketed chips, that seemed to improve things, but I still get graphical garbage when starting it sometimes. I also noticed that when shutting it off, to restart it again, sometimes it doesn't clear the memory. I resorted to shutting it off, pulling the plug, turning it in a few times, then replugging it and starting it up again. Not sure what the deal is, disk controller problem, bad memory, or something else.

Log in or register to post comments