eeun

Primary tabs

TypeTitleAuthorRepliesLast updated
Forum topicPowermac 8600 USB Card? smileyranger51 month 2 weeks ago
Forum topicRasberry pi running native os megadrive4511163 months 1 week ago
Forum topicImac G4 Green Tint on the Screen crazy jermy85 months 3 weeks ago
Forum topiciPod Shuffle Will Not Mount BDub79 months 2 weeks ago
Forum topicRunning a G3 AIO Motherboard without the personality card? Oguk289 months 2 weeks ago
Forum topiciMac G4 Dead Power Supply dandeliondigital109 months 2 weeks ago
Forum topicmagnets and CRT's coius59 months 2 weeks ago
Forum topicwhite spots on the screen? lqbweb59 months 2 weeks ago
Forum topicRe-install Imac tray load OS using Performa 6320? dhjsllc69 months 2 weeks ago
Forum topicOrange imac memory tbyrd51169 months 2 weeks ago
Forum topicApple Computer Inc 820-1096-A logic board Question? tschiska29 months 2 weeks ago
Forum topiccleaning canon printhead scottbird19 months 2 weeks ago
Forum topicPower Supply questions - Quicksilver (2001) & blue/white g3 mrx19 months 2 weeks ago
Forum topicupdated TiBook display repair page dankephoto39 months 2 weeks ago
Forum topicg3 trayload 333mhz brulaheliko99 months 2 weeks ago
Forum topicB&W G3 not recognising my IDE PCI card iamdigitalman89 months 2 weeks ago
Forum topicIIsi; white screen on boot up; no chime; bad PRAM battery? doug-doug the mighty99 months 2 weeks ago
Forum topicG3-500 "Dalmation" with a screen flicker. Only happens at 1024 x 768 @ 75hz Rasorial129 months 2 weeks ago
Forum topicCD-RW frtzed out in G4 Quicksilver Inkwolf59 months 2 weeks ago
Forum topicPS\2 to ADB DaveyPocket19 months 2 weeks ago
Forum topicCracked LCD in lampshade iMac doug-doug the mighty49 months 2 weeks ago
Forum topicB&W G3 motherboard Contradude69 months 2 weeks ago
Forum topicImac 400 DV SE mod plumpcrazy29 months 2 weeks ago
Forum topicG4 Processor Damage Hawaii Cruiser59 months 2 weeks ago
Forum topicStupid Question about G4 PSU tmtomh19 months 2 weeks ago

Pages