Mike WIllegal

Primary tabs

TypeTitleAuthorRepliesLast updated
Forum topicUsing Mimeo 1 in UK, Europe or Australia - Newbie question lazarusr152 years 9 months ago
Forum topicMimeo 1 Build - Part 3 - making progress ... slowly Sherlock202 years 9 months ago
Forum topicMimeo 1 Build - Keyboard Options Sherlock182 years 9 months ago
Forum topicApple II Plus color killer circuit rittwage32 years 9 months ago
Forum topicMimeo 1 Build - Part 2 - Video Sherlock192 years 9 months ago
Forum topicApple II Prototype photos (was: Early Apple II photos) mmaginnis162 years 9 months ago
Forum topicMimeo 1 Build - Problems with blowing fuses Sherlock532 years 10 months ago
Forum topicNew Apple 1 auction from Christie's GIULIOBIT62 years 10 months ago
Forum topicInteresting Device #3 BillO32 years 11 months ago
Forum topicEarly Apple II Owners 1978AppleII102 years 11 months ago
Forum topicProblem running BASIC? wheagy72 years 11 months ago
Forum topicApple-1 Koa wood cases Corey98632 years 12 months ago
Forum topicApple II raised power light Jepple103 years 5 days ago
Forum topicApple II case lid history Jepple33 years 1 week ago
Forum topicApple II rom card switch; where can I find one? transwarp II guy123 years 2 weeks ago
Forum topicApple 1 correct MCS6502 on eBay PhilPower113 years 3 weeks ago
Forum topicMy new Apple II 1978AppleII123 years 1 month ago
Forum topicBuilding my first clone Sephiroth8723 years 1 month ago
Forum topicA good day on eBay billw93 years 1 month ago
Forum topicMonitor II on the fritz CWJ_Wilko233 years 1 month ago
Forum topicLM320 voltages? wheagy43 years 1 month ago
Forum topicHistory of Disk II production CWJ_Wilko103 years 2 months ago
Forum topicApple 1 garage find! PhilPower63 years 2 months ago
Forum topicInteger BASIC on Apple IIe via tape? GameOn123 years 2 months ago
Forum topicACI workaround for Replica 1 Plus? resurgam83 years 3 months ago

Pages